aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorglarkin <glarkin@FreeBSD.org>2010-02-25 05:48:26 +0800
committerglarkin <glarkin@FreeBSD.org>2010-02-25 05:48:26 +0800
commit79d9bdb8be6b754a96a57e60c47a7cf9581d5a21 (patch)
tree0f8b8fa5a857e490a1d74e2a726bf8a95989ad13
parent60e1aaedb27de844872cb5eb14691a83f635b5be (diff)
downloadfreebsd-ports-gnome-79d9bdb8be6b754a96a57e60c47a7cf9581d5a21.tar.gz
freebsd-ports-gnome-79d9bdb8be6b754a96a57e60c47a7cf9581d5a21.tar.zst
freebsd-ports-gnome-79d9bdb8be6b754a96a57e60c47a7cf9581d5a21.zip
- Use $SUB_FILES to dynamically adjust pkg-message [1]
- Support cross-platform installation by suppression of stripping for precompiled binary [2] - Change MAINTAINER e-mail [2] - Group ARCH-dependent lines together [2] - Replace dead WWW link with living mirror [2] - Make it clearly visible that the software is effectively "abandonware" for now [2] - Added i386 dependency on crypto.so.3 (misc/compat5x) PR: ports/143096 Submitted by: Sevan Janiyan <venture37@geeklan.co.uk> Approved by: Eugene Grosbein <egrosbein@rdtc.ru> (maintainer) [2] Feature safe: yes
-rw-r--r--net/AquaGatekeeper/Makefile20
-rw-r--r--net/AquaGatekeeper/files/pkg-message.in9
-rw-r--r--net/AquaGatekeeper/pkg-descr8
-rw-r--r--net/AquaGatekeeper/pkg-message5
4 files changed, 26 insertions, 16 deletions
diff --git a/net/AquaGatekeeper/Makefile b/net/AquaGatekeeper/Makefile
index d66da058e8d7..d6d0c4d51978 100644
--- a/net/AquaGatekeeper/Makefile
+++ b/net/AquaGatekeeper/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= ftp://ftp.svzserv.kemerovo.su/pub/FreeBSD/distfiles.misc/ \
ftp://www.kuzbass.ru/pub/FreeBSD/ports/distfiles/
EXTRACT_SUFX= .tgz
-MAINTAINER= eugen@grosbein.pp.ru
+MAINTAINER= ports@grosbein.pp.ru
COMMENT= Aqua H323 Gatekeeper and proxy
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -22,6 +22,10 @@ ONLY_FOR_ARCHS= amd64 i386
MD5_FILE= ${MASTERDIR}/distinfo.${ARCH}
RESTRICTED= No commercial redistribution
+SUB_FILES= pkg-message
+STRIP=
+STRIP_CMD= ${TRUE}
+DEPRECATED= Binary port of software abandoned by the vendor
.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
IS_INTERACTIVE= yes
@@ -46,20 +50,18 @@ do-install:
post-install:
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
- @${SED} "s'%%PREFIX%%'${PREFIX}'" < pkg-message
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.pre.mk>
+# This is binary port of closed-source software
.if ${ARCH} == "i386"
-LIB_DEPENDS= c.4:${PORTSDIR}/misc/compat4x
+DISTNAME= AquaGatekeeper122FreeBSDBuild445
+LIB_DEPENDS= c.4:${PORTSDIR}/misc/compat4x \
+ crypto.3:${PORTSDIR}/misc/compat5x
.elif ${ARCH} == "amd64"
-LIB_DEPENDS= c.5:${PORTSDIR}/misc/compat5x
-.endif
-
-.if ${ARCH} == "amd64"
DISTNAME= AquaGatekeeper122FreeBSDamd64Build131
-.else
-DISTNAME= AquaGatekeeper122FreeBSDBuild445
+LIB_DEPENDS= c.5:${PORTSDIR}/misc/compat5x
.endif
.include <bsd.port.post.mk>
diff --git a/net/AquaGatekeeper/files/pkg-message.in b/net/AquaGatekeeper/files/pkg-message.in
new file mode 100644
index 000000000000..32d73093b4b3
--- /dev/null
+++ b/net/AquaGatekeeper/files/pkg-message.in
@@ -0,0 +1,9 @@
+****************************************************************************
+!!! NOTE: THE AQUA GATEKEEPER IS DISCONTIUED BY ITS VENDOR. No vendor support,
+!!! no updates, no bugfixes. This port is still provided to support
+!!! old installations only. You should choose other software for new setups.
+
+ Please read documentation located in %%DOCSDIR%%
+ You will need to write configuration file to run the Gatekeeper.
+ Some examples are in %%EXAMPLESDIR%%
+****************************************************************************
diff --git a/net/AquaGatekeeper/pkg-descr b/net/AquaGatekeeper/pkg-descr
index a8ba595db4a2..c04b9a470f40 100644
--- a/net/AquaGatekeeper/pkg-descr
+++ b/net/AquaGatekeeper/pkg-descr
@@ -6,7 +6,11 @@ This port presents Aqua Gatekeeper Startup Edition.
It is not a free software but may be used free of charge.
The Aqua Gatekeeper Startup Edition is limited to 30 concurrent calls.
-WWW: http://www.aqua.comptek.ru/man/voip/gatekeeper/index.htm
+!!! NOTE: THE AQUA GATEKEEPER IS DISCONTIUED BY ITS VENDOR. No vendor support,
+!!! no updates, no bugfixes. This port is still provided to support
+!!! old installations only. You should choose other software for new setups.
+
+WWW: http://www.kuzbass.ru/docs/AquaGatekeeper/AquaGatekeeper.htm
- Grosbein
-eugen@grosbein.pp.ru
+ports@grosbein.pp.ru
diff --git a/net/AquaGatekeeper/pkg-message b/net/AquaGatekeeper/pkg-message
deleted file mode 100644
index 005fb0e618f2..000000000000
--- a/net/AquaGatekeeper/pkg-message
+++ /dev/null
@@ -1,5 +0,0 @@
-****************************************************************************
- Please read documentation located in %%PREFIX%%/share/doc/AquaGatekeeper
- You will need to write configuration file to run the Gatekeeper.
- Some examples are in %%PREFIX%%/share/examples/AquaGatekeeper
-****************************************************************************