aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2019-02-18 03:40:52 +0800
committersunpoet <sunpoet@FreeBSD.org>2019-02-18 03:40:52 +0800
commit7c787ccc33c5378a315d29bc8de1f398ec56a6f4 (patch)
tree7d2fdfe55b7c42988a64c9cd7506bdbde66e788a
parentdce2af603d39f96e46f1ab831b1b7444841437b1 (diff)
downloadfreebsd-ports-gnome-7c787ccc33c5378a315d29bc8de1f398ec56a6f4.tar.gz
freebsd-ports-gnome-7c787ccc33c5378a315d29bc8de1f398ec56a6f4.tar.zst
freebsd-ports-gnome-7c787ccc33c5378a315d29bc8de1f398ec56a6f4.zip
Update to 0.6.2
Changes: https://github.com/Nuitka/Nuitka/blob/develop/Changelog.rst
-rw-r--r--devel/nuitka/Makefile2
-rw-r--r--devel/nuitka/distinfo6
-rw-r--r--devel/nuitka/files/patch-nuitka_build_SingleExe.scons20
3 files changed, 14 insertions, 14 deletions
diff --git a/devel/nuitka/Makefile b/devel/nuitka/Makefile
index 62102cb56a71..a1fdc6474d56 100644
--- a/devel/nuitka/Makefile
+++ b/devel/nuitka/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= nuitka
-PORTVERSION= 0.6.1.1
+PORTVERSION= 0.6.2
CATEGORIES= devel python
MASTER_SITES= https://nuitka.net/releases/
DISTNAME= Nuitka-${PORTVERSION}
diff --git a/devel/nuitka/distinfo b/devel/nuitka/distinfo
index 61ed32b919ce..4bf52c3bb82f 100644
--- a/devel/nuitka/distinfo
+++ b/devel/nuitka/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1548417310
-SHA256 (Nuitka-0.6.1.1.tar.bz2) = 216cffc077a1c3e1ad8b90f44839c5c887a436aa0833b67c63a964c9e8e5b374
-SIZE (Nuitka-0.6.1.1.tar.bz2) = 1545765
+TIMESTAMP = 1550415399
+SHA256 (Nuitka-0.6.2.tar.bz2) = 843a4f4d401113bfbfa3c77e0c159433da213f1368abed2248097d654bf3aeb8
+SIZE (Nuitka-0.6.2.tar.bz2) = 1562536
diff --git a/devel/nuitka/files/patch-nuitka_build_SingleExe.scons b/devel/nuitka/files/patch-nuitka_build_SingleExe.scons
index ef68003eef95..6f16eebae0e5 100644
--- a/devel/nuitka/files/patch-nuitka_build_SingleExe.scons
+++ b/devel/nuitka/files/patch-nuitka_build_SingleExe.scons
@@ -1,18 +1,18 @@
---- nuitka/build/SingleExe.scons.orig 2019-01-05 11:46:56 UTC
+--- nuitka/build/SingleExe.scons.orig 2019-02-16 07:51:41 UTC
+++ nuitka/build/SingleExe.scons
-@@ -135,9 +135,9 @@ uninstalled_python = getBoolOption("unin
+@@ -138,9 +138,10 @@ uninstalled_python = getBoolOption("unin
# Unstriped mode: Do not remove debug symbols.
unstripped_mode = getBoolOption("unstripped_mode", False)
--# Clang compiler mode, forced on MacOS X and FreeBSD, optional on Linux.
-+# Clang compiler mode, forced on MacOS X and FreeBSD (unless PowerPC), optional on Linux.
+-# Clang compiler mode, forced on macOS X and FreeBSD, optional on Linux.
++# Clang compiler mode, forced on macOS and FreeBSD (excluding PowerPC), optional on Linux.
clang_mode = getBoolOption("clang_mode", False)
--if macosx_target or "freebsd" in sys.platform:
-+if macosx_target or ("freebsd" in sys.platform and platform.machine() != "powerpc"):
+ if macosx_target or "freebsd" in sys.platform:
++if macosx_target or ("freebsd" in sys.platform and os.uname()[4] != "powerpc"):
clang_mode = True
# MinGW compiler mode, optional and interesting to Windows only.
-@@ -746,11 +746,11 @@ if gcc_mode and "clang" not in the_cc_na
+@@ -751,11 +752,11 @@ if gcc_mode and "clang" not in the_cc_na
# binary if it's not high enough. This is esp. useful under Debian which
# allows all compiler to exist next to each other and where g++ might not be
# good enough, but g++-4.5 would be.
@@ -21,8 +21,8 @@
sys.exit(
"""\
The gcc compiler %s (version %s) doesn't have the sufficient \
--version (>= 4.4).""" % (the_compiler, gcc_version)
-+version (>= 4.2.1).""" % (the_compiler, gcc_version)
+-version (>= 4.4)."""
++version (>= 4.2.1)."""
+ % (the_compiler, gcc_version)
)
- # CondaCC or newer.