aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2013-12-15 18:18:00 +0800
committerohauer <ohauer@FreeBSD.org>2013-12-15 18:18:00 +0800
commit85b1f7183950ba90f097c7eb4c1b95839c655fc7 (patch)
tree2bf711e3ec11bcc0cfe6dcd1f111e337bf81a626
parent7db63969cf6bb9cc5f98421458a79c0485888f16 (diff)
downloadfreebsd-ports-gnome-85b1f7183950ba90f097c7eb4c1b95839c655fc7.tar.gz
freebsd-ports-gnome-85b1f7183950ba90f097c7eb4c1b95839c655fc7.tar.zst
freebsd-ports-gnome-85b1f7183950ba90f097c7eb4c1b95839c655fc7.zip
- change to new LIB_DEPENDS notation
- s/LATEST_LINK/PKGNAMESUFFIX/
-rw-r--r--www/mod_auth_kerb2/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/www/mod_auth_kerb2/Makefile b/www/mod_auth_kerb2/Makefile
index 4ad5a25782de..747c5d05b79c 100644
--- a/www/mod_auth_kerb2/Makefile
+++ b/www/mod_auth_kerb2/Makefile
@@ -7,13 +7,12 @@ PORTREVISION= 5
CATEGORIES= www
MASTER_SITES= SF/modauthkerb/${PORTNAME}/${PORTNAME}-${PORTVERSION}
PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 2
MAINTAINER= apache@FreeBSD.org
-COMMENT= An Apache module for authenticating users with Kerberos v5
-
-
-LATEST_LINK= mod_auth_kerb2
+COMMENT= Apache module for authenticating users with Kerberos v5
+NO_STAGE= yes
USE_APACHE= 22
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -21,22 +20,21 @@ GNU_CONFIGURE= yes
PORTSCOUT= limit:^5.4
.if defined(KRB5_HOME)
-BUILD_DEPENDS+= ${KRB5_HOME}/lib/libgssapi_krb5.so:${PORTSDIR}/security/krb5
-RUN_DEPENDS+= ${KRB5_HOME}/lib/libgssapi_krb5.so:${PORTSDIR}/security/krb5
+BUILD_DEPENDS+= ${KRB5_HOME}/lib/libgssapi_krb5.so:${PORTSDIR}/security/krb5
+RUN_DEPENDS+= ${KRB5_HOME}/lib/libgssapi_krb5.so:${PORTSDIR}/security/krb5
CONFIGURE_ARGS+= --with-krb5=${KRB5_HOME} --without-krb4
.elif defined(HEIMDAL_HOME)
-BUILD_DEPENDS+= ${HEIMDAL_HOME}/lib/libgssapi.so:${PORTSDIR}/security/heimdal
-RUN_DEPENDS+= ${HEIMDAL_HOME}/lib/libgssapi.so:${PORTSDIR}/security/heimdal
+BUILD_DEPENDS+= ${HEIMDAL_HOME}/lib/libgssapi.so:${PORTSDIR}/security/heimdal
+RUN_DEPENDS+= ${HEIMDAL_HOME}/lib/libgssapi.so:${PORTSDIR}/security/heimdal
CONFIGURE_ARGS+= --with-krb5=${HEIMDAL_HOME} --without-krb4
.elif exists(${DESTDIR}/usr/lib/libkrb5.a) && exists(${DESTDIR}/usr/bin/krb5-config)
CONFIGURE_ARGS+= --with-krb5=${DESTDIR}/usr --without-krb4
.else
-LIB_DEPENDS+= gssapi_krb5:${PORTSDIR}/security/krb5
+LIB_DEPENDS+= libgssapi_krb5.so:${PORTSDIR}/security/krb5
CONFIGURE_ARGS+= --with-krb5=${LOCALBASE} --without-krb4
.endif
-NO_STAGE= yes
.include <bsd.port.mk>