aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsergei <sergei@FreeBSD.org>2006-09-20 18:40:31 +0800
committersergei <sergei@FreeBSD.org>2006-09-20 18:40:31 +0800
commit8b764be8998918faef616ad1a659aaff32531fcc (patch)
treebd263aa937d081dee06a0405265bc2ccba532ac5
parent114690492edd0b8900e96773bf59f62cc2d096b0 (diff)
downloadfreebsd-ports-gnome-8b764be8998918faef616ad1a659aaff32531fcc.tar.gz
freebsd-ports-gnome-8b764be8998918faef616ad1a659aaff32531fcc.tar.zst
freebsd-ports-gnome-8b764be8998918faef616ad1a659aaff32531fcc.zip
- Unbreak: the self-tests included with bglibs contains several
network related tests (namely, in net/connect4.c and net/tcp4.c) that fails in our package build cluster environment. Thus, disable running self-tests during build process - create a separate "selftest" Makefile target that would allow users to run self-tests manually with "make selftest" - Add USE_LDCONFIG Nagged by: pointyhat via kris Discussed with: oliver
-rw-r--r--devel/bglibs/Makefile8
-rw-r--r--devel/bglibs/files/patch-Makefile11
2 files changed, 15 insertions, 4 deletions
diff --git a/devel/bglibs/Makefile b/devel/bglibs/Makefile
index 0ef942a1d661..887dd2d428c7 100644
--- a/devel/bglibs/Makefile
+++ b/devel/bglibs/Makefile
@@ -13,10 +13,6 @@ MASTER_SITES= http://untroubled.org/${PORTNAME}/
MAINTAINER= sergei@FreeBSD.org
COMMENT= One stop library package by Bruce Guenter
-BROKEN= Fails self-tests
-DEPRECATED= ${BROKEN}
-EXPIRATION_DATE=2006-12-01
-
NOT_FOR_ARCHS= alpha
USE_GPG= yes
@@ -27,6 +23,7 @@ USE_AUTOTOOLS= libtool:15:env
LDFLAGS?= -s
BGLIBS_INC= ${PREFIX}/include/${PORTNAME}
BGLIBS_LIB= ${PREFIX}/lib/${PORTNAME}
+USE_LDCONFIG= ${BGLIBS_LIB}
DOCS= NEWS README TODO doc/html/*
MAN1= cli-generate.1
@@ -46,4 +43,7 @@ post-install:
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif
+selftest: build
+ cd ${WRKSRC} && ${SH} selftests.sh
+
.include <bsd.port.mk>
diff --git a/devel/bglibs/files/patch-Makefile b/devel/bglibs/files/patch-Makefile
new file mode 100644
index 000000000000..297833ea4fd3
--- /dev/null
+++ b/devel/bglibs/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig Wed Sep 20 13:44:49 2006
++++ Makefile Wed Sep 20 13:45:05 2006
+@@ -126,7 +126,7 @@ adt/hashs.lo: libcompile adt/hashs.c adt
+ adt/hashs.o: compile adt/hashs.c adt/common.h
+ ./compile adt/hashs.c
+
+-all: dotlibs sysdeps.h libraries bg-installer cli-generate selftests
++all: dotlibs sysdeps.h libraries bg-installer cli-generate
+
+ base64/asc2bin.lo: libcompile base64/asc2bin.c base64/base64.h str/str.h
+ ./libcompile base64/asc2bin.c