aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2008-06-26 02:06:55 +0800
committerdinoex <dinoex@FreeBSD.org>2008-06-26 02:06:55 +0800
commit8cb30d97e8342b5ccc47c9bf819b753a523dbd92 (patch)
tree58cd1b681c1a78267fe0422e0488527c95dccb61
parent47ec8cc0a84fd18ce32b0d90c4c01d01131cc747 (diff)
downloadfreebsd-ports-gnome-8cb30d97e8342b5ccc47c9bf819b753a523dbd92.tar.gz
freebsd-ports-gnome-8cb30d97e8342b5ccc47c9bf819b753a523dbd92.tar.zst
freebsd-ports-gnome-8cb30d97e8342b5ccc47c9bf819b753a523dbd92.zip
- enable cryptodev
124972 PR: 124972 Submitted by: Larry Baird Obtained from: Simon L. Nielsen
-rw-r--r--security/openssl/Makefile2
-rw-r--r--security/openssl/files-beta/patch-eng_cryptodev.c12
2 files changed, 13 insertions, 1 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 97ad10b0b72a..acc7d8932207 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -11,7 +11,7 @@ PORTVERSION= 0.9.7m
PORTREVISION?= 0
.else
PORTVERSION= 0.9.8h
-PORTREVISION?= 0
+PORTREVISION?= 1
.endif
CATEGORIES= security devel
MASTER_SITES= http://www.openssl.org/%SUBDIR%/ \
diff --git a/security/openssl/files-beta/patch-eng_cryptodev.c b/security/openssl/files-beta/patch-eng_cryptodev.c
new file mode 100644
index 000000000000..3746331dacf4
--- /dev/null
+++ b/security/openssl/files-beta/patch-eng_cryptodev.c
@@ -0,0 +1,12 @@
+diff -ru openssl-0.9.8g.orig/crypto/engine/eng_cryptodev.c crypto/engine/eng_cryptodev.c
+--- openssl-0.9.8g.orig/crypto/engine/eng_cryptodev.c 2004-06-15 13:45:42.000000000 +0200
++++ crypto/engine/eng_cryptodev.c 2007-12-16 11:15:12.000000000 +0100
+@@ -32,7 +32,7 @@
+ #include <openssl/bn.h>
+
+ #if (defined(__unix__) || defined(unix)) && !defined(USG) && \
+- (defined(OpenBSD) || defined(__FreeBSD_version))
++ (defined(OpenBSD) || defined(__FreeBSD__))
+ #include <sys/param.h>
+ # if (OpenBSD >= 200112) || ((__FreeBSD_version >= 470101 && __FreeBSD_version < 500000) || __FreeBSD_version >= 500041)
+ # define HAVE_CRYPTODEV