aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2010-04-30 05:47:35 +0800
committerkwm <kwm@FreeBSD.org>2010-04-30 05:47:35 +0800
commit9a1245e63f98ff95330aa6dcf6ec421b093c6a72 (patch)
treeaeb210bc89e1c670521af6e0810427522590f3fd
parentf4f19ba2e750e4f282adf7b5431d82e70e1a9d3f (diff)
downloadfreebsd-ports-gnome-9a1245e63f98ff95330aa6dcf6ec421b093c6a72.tar.gz
freebsd-ports-gnome-9a1245e63f98ff95330aa6dcf6ec421b093c6a72.tar.zst
freebsd-ports-gnome-9a1245e63f98ff95330aa6dcf6ec421b093c6a72.zip
Update to 0.1.10.
Add more drivers. Fix double buffering of BULK transfers. Fix incorrectly defined FE_GET_PROPERTY ioctl for which the workaround as used in the Linux drivers doesn't work on FreeBSD; more details in this thread: http://lists.freebsd.org/pipermail/freebsd-multimedia/2010-April/010958.html [1] Submitted by: Hans Petter Selasky <hselasky@c2i.net> (maintainer) Juergen Lock <nox@jelal.kn-bremen.de> [1]
-rw-r--r--multimedia/webcamd/Makefile4
-rw-r--r--multimedia/webcamd/distinfo6
-rw-r--r--multimedia/webcamd/files/patch-dvb_frontend.h11
3 files changed, 16 insertions, 5 deletions
diff --git a/multimedia/webcamd/Makefile b/multimedia/webcamd/Makefile
index 12bc0c0f9657..a1e6642a7043 100644
--- a/multimedia/webcamd/Makefile
+++ b/multimedia/webcamd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= webcamd
-PORTVERSION= 0.1.8
+PORTVERSION= 0.1.10
CATEGORIES= multimedia
MASTER_SITES= http://www.selasky.org/hans_petter/video4bsd/releases/
@@ -31,7 +31,7 @@ IGNORE= requires FreeBSD 8.0-RELEASE or later
.endif
post-patch:
- cd ${WRKSRC}/patches; ${SH} ./do_patch.sh
+ @cd ${WRKSRC}/patches; ${SH} ./do_patch.sh
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/Makefile
post-install:
diff --git a/multimedia/webcamd/distinfo b/multimedia/webcamd/distinfo
index 44cadca8452b..fd9be6bab5c8 100644
--- a/multimedia/webcamd/distinfo
+++ b/multimedia/webcamd/distinfo
@@ -1,3 +1,3 @@
-MD5 (webcamd-0.1.8.tar.bz2) = 9c5fbc776b4b2b60f2f7d1d4c258bfdd
-SHA256 (webcamd-0.1.8.tar.bz2) = d4cef4cc30e9be784e66732f25689edade9a3feba2e3718b240a68d4c68d98f8
-SIZE (webcamd-0.1.8.tar.bz2) = 3512154
+MD5 (webcamd-0.1.10.tar.bz2) = 7c83bf7da633991fa5386bfff27a1c2c
+SHA256 (webcamd-0.1.10.tar.bz2) = 53ba99ee49f7548b90feecf08d8257d086436c5f8a08eeef4ac7c1ad44087152
+SIZE (webcamd-0.1.10.tar.bz2) = 3521742
diff --git a/multimedia/webcamd/files/patch-dvb_frontend.h b/multimedia/webcamd/files/patch-dvb_frontend.h
new file mode 100644
index 000000000000..e81a804f1a55
--- /dev/null
+++ b/multimedia/webcamd/files/patch-dvb_frontend.h
@@ -0,0 +1,11 @@
+--- v4l-dvb/linux/include/linux/dvb/frontend.h.orig 2010-03-19 03:47:27.000000000 +0100
++++ v4l-dvb/linux/include/linux/dvb/frontend.h 2010-04-15 13:00:04.000000000 +0200
+@@ -373,7 +373,7 @@
+ };
+
+ #define FE_SET_PROPERTY _IOW('o', 82, struct dtv_properties)
+-#define FE_GET_PROPERTY _IOR('o', 83, struct dtv_properties)
++#define FE_GET_PROPERTY _IOW('o', 83, struct dtv_properties)
+
+
+ /**