aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2009-08-02 03:29:44 +0800
committermarcus <marcus@FreeBSD.org>2009-08-02 03:29:44 +0800
commita30d8b2e049f9c49d95a2ace35312d022eecbd60 (patch)
tree523ad00ea201c9a7cd0390a4a0bcfc5da08109ba
parentc4ffc9702b9abc4dad904914efc161f5d182dbda (diff)
downloadfreebsd-ports-gnome-a30d8b2e049f9c49d95a2ace35312d022eecbd60.tar.gz
freebsd-ports-gnome-a30d8b2e049f9c49d95a2ace35312d022eecbd60.tar.zst
freebsd-ports-gnome-a30d8b2e049f9c49d95a2ace35312d022eecbd60.zip
Fix portability issues with newer gpgme.
-rw-r--r--security/seahorse-plugins/Makefile2
-rw-r--r--security/seahorse-plugins/files/patch-agent_seahorse-agent-cache.c10
-rw-r--r--security/seahorse-plugins/files/patch-libseahorse_seahorse-pgp-operation.c10
-rw-r--r--security/seahorse-plugins/files/patch-plugins_nautilus_seahorse-tool.c23
-rw-r--r--security/seahorse/Makefile2
-rw-r--r--security/seahorse/files/patch-daemon_seahorse-hkp-server.c13
-rw-r--r--security/seahorse/files/patch-pgp_seahorse-gpgme-source.c10
7 files changed, 68 insertions, 2 deletions
diff --git a/security/seahorse-plugins/Makefile b/security/seahorse-plugins/Makefile
index 10e2400db4f1..a6043f5e2eb2 100644
--- a/security/seahorse-plugins/Makefile
+++ b/security/seahorse-plugins/Makefile
@@ -8,7 +8,7 @@
PORTNAME= seahorse-plugins
PORTVERSION= 2.26.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
diff --git a/security/seahorse-plugins/files/patch-agent_seahorse-agent-cache.c b/security/seahorse-plugins/files/patch-agent_seahorse-agent-cache.c
new file mode 100644
index 000000000000..70d1c926104c
--- /dev/null
+++ b/security/seahorse-plugins/files/patch-agent_seahorse-agent-cache.c
@@ -0,0 +1,10 @@
+--- agent/seahorse-agent-cache.c.orig 2009-08-01 15:25:55.000000000 -0400
++++ agent/seahorse-agent-cache.c 2009-08-01 15:23:38.000000000 -0400
+@@ -237,6 +237,7 @@ seahorse_agent_cache_init ()
+ g_cache =
+ g_hash_table_new_full (g_str_hash, g_str_equal, NULL, destroy_cache_item);
+
++ gpgme_check_version (NULL);
+ err = gpgme_engine_check_version (proto);
+ g_return_if_fail (GPG_IS_OK (err));
+
diff --git a/security/seahorse-plugins/files/patch-libseahorse_seahorse-pgp-operation.c b/security/seahorse-plugins/files/patch-libseahorse_seahorse-pgp-operation.c
new file mode 100644
index 000000000000..16c64303be80
--- /dev/null
+++ b/security/seahorse-plugins/files/patch-libseahorse_seahorse-pgp-operation.c
@@ -0,0 +1,10 @@
+--- libseahorse/seahorse-pgp-operation.c.orig 2009-08-01 15:26:28.000000000 -0400
++++ libseahorse/seahorse-pgp-operation.c 2009-08-01 15:23:41.000000000 -0400
+@@ -323,6 +323,7 @@ seahorse_pgp_operation_init (SeahorsePGP
+ gpgme_error_t err;
+ gpgme_ctx_t ctx;
+
++ gpgme_check_version (NULL);
+ err = gpgme_engine_check_version (proto);
+ g_return_if_fail (GPG_IS_OK (err));
+
diff --git a/security/seahorse-plugins/files/patch-plugins_nautilus_seahorse-tool.c b/security/seahorse-plugins/files/patch-plugins_nautilus_seahorse-tool.c
new file mode 100644
index 000000000000..f871ce6a9e32
--- /dev/null
+++ b/security/seahorse-plugins/files/patch-plugins_nautilus_seahorse-tool.c
@@ -0,0 +1,23 @@
+--- plugins/nuatilus/seahorse-tool.c.orig 2009-08-01 15:27:07.000000000 -0400
++++ plugins/nuatilus/seahorse-tool.c 2009-08-01 15:23:46.000000000 -0400
+@@ -171,6 +171,9 @@ prompt_recipients (gpgme_key_t *signkey)
+
+ if (recips) {
+
++ gpgme_check_version (NULL);
++ gerr = gpgme_engine_check_version (GPGME_PROTOCOL_OpenPGP);
++ g_return_val_if_fail (GPG_IS_OK (gerr), NULL);
+ gerr = gpgme_new (&ctx);
+ g_return_val_if_fail (GPG_IS_OK (gerr), NULL);
+
+@@ -327,6 +330,10 @@ prompt_signer ()
+
+ id = cryptui_keyset_key_raw_keyid (keyset, signer);
+ g_free (signer);
++
++ gpgme_check_version (NULL);
++ gerr = gpgme_engine_check_version (GPGME_PROTOCOL_OpenPGP);
++ g_return_val_if_fail (GPG_IS_OK (gerr), NULL);
+
+ gerr = gpgme_new (&ctx);
+ g_return_val_if_fail (GPG_IS_OK (gerr), NULL);
diff --git a/security/seahorse/Makefile b/security/seahorse/Makefile
index d9fb84368cdd..56c3406a2513 100644
--- a/security/seahorse/Makefile
+++ b/security/seahorse/Makefile
@@ -8,7 +8,7 @@
PORTNAME= seahorse
PORTVERSION= 2.26.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
diff --git a/security/seahorse/files/patch-daemon_seahorse-hkp-server.c b/security/seahorse/files/patch-daemon_seahorse-hkp-server.c
new file mode 100644
index 000000000000..1880aad325a3
--- /dev/null
+++ b/security/seahorse/files/patch-daemon_seahorse-hkp-server.c
@@ -0,0 +1,13 @@
+--- daemon/seahorse-hkp-server.c.orig 2009-08-01 15:25:02.000000000 -0400
++++ daemon/seahorse-hkp-server.c 2009-08-01 15:23:27.000000000 -0400
+@@ -467,7 +467,9 @@ seahorse_hkp_server_start(GError **err)
+ /* Initialize GPGME context */
+ if (gpgme_ctx == NULL) {
+ gpgme_protocol_t proto = GPGME_PROTOCOL_OpenPGP;
+- gpgme_error_t err = gpgme_engine_check_version (proto);
++ gpgme_error_t err;
++ gpgme_check_version (NULL);
++ err = gpgme_engine_check_version (proto);
+ g_return_val_if_fail (GPG_IS_OK (err), FALSE);
+
+ err = gpgme_new (&gpgme_ctx);
diff --git a/security/seahorse/files/patch-pgp_seahorse-gpgme-source.c b/security/seahorse/files/patch-pgp_seahorse-gpgme-source.c
new file mode 100644
index 000000000000..b036a81571df
--- /dev/null
+++ b/security/seahorse/files/patch-pgp_seahorse-gpgme-source.c
@@ -0,0 +1,10 @@
+--- pgp/seahorse-gpgme-source.c.orig 2009-08-01 15:24:28.000000000 -0400
++++ pgp/seahorse-gpgme-source.c 2009-08-01 15:23:24.000000000 -0400
+@@ -139,6 +139,7 @@ init_gpgme (gpgme_ctx_t *ctx)
+ gpgme_protocol_t proto = GPGME_PROTOCOL_OpenPGP;
+ gpgme_error_t err;
+
++ gpgme_check_version (NULL);
+ err = gpgme_engine_check_version (proto);
+ g_return_val_if_fail (GPG_IS_OK (err), err);
+