aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2004-02-12 22:24:55 +0800
committerale <ale@FreeBSD.org>2004-02-12 22:24:55 +0800
commita3e75eb112ff1c698ddf9eae68645687cebd4f3a (patch)
treedfd6f04299b7b187f427d9bd9758850e0138339b
parent2f1c74a0540940722b38c354150fbd0708dabd5c (diff)
downloadfreebsd-ports-gnome-a3e75eb112ff1c698ddf9eae68645687cebd4f3a.tar.gz
freebsd-ports-gnome-a3e75eb112ff1c698ddf9eae68645687cebd4f3a.tar.zst
freebsd-ports-gnome-a3e75eb112ff1c698ddf9eae68645687cebd4f3a.zip
Use PTHREAD_LIBS only if OSVERSION >= 500016.
This fixes compilation of mod_php with apache2-worker on -stable. PR: ports/62729 Submitted by: Maxim Maximov <mcsi@portpc-design.spb.ru> Approved by: nork (mentor/implicitly)
-rw-r--r--lang/php4/Makefile13
-rw-r--r--lang/php5/Makefile13
-rw-r--r--lang/php53/Makefile13
3 files changed, 21 insertions, 18 deletions
diff --git a/lang/php4/Makefile b/lang/php4/Makefile
index f6f1a3d268da..a66a1d605f23 100644
--- a/lang/php4/Makefile
+++ b/lang/php4/Makefile
@@ -67,12 +67,6 @@ GNU_CONFIGURE= yes
USE_BISON= yes
USE_REINPLACE= yes
-WITH_PTHREAD_LIBS?= ${PTHREAD_LIBS:S/-l//}
-WITH_PTHREAD_CFLAGS?= ${PTHREAD_CFLAGS}
-
-CONFIGURE_ENV= ac_cv_pthreads_lib=${WITH_PTHREAD_LIBS} \
- ac_cv_pthreads_cflags=${WITH_PTHREAD_CFLAGS}
-
CONFIGURE_ARGS= --enable-versioning \
--enable-memory-limit \
--with-layout=GNU \
@@ -553,6 +547,13 @@ CONFIGURE_ARGS+=--with-zlib=yes
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 500016
+WITH_PTHREAD_LIBS?= ${PTHREAD_LIBS:S/-l//}
+WITH_PTHREAD_CFLAGS?= ${PTHREAD_CFLAGS}
+CONFIGURE_ENV= ac_cv_pthreads_lib=${WITH_PTHREAD_LIBS} \
+ ac_cv_pthreads_cflags=${WITH_PTHREAD_CFLAGS}
+.endif
+
.if !defined(WITHOUT_APACHE)
.if exists(${LOCALBASE}/include/apache2/httpd.h)
WITH_APACHE2= yes
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index 693aecc26b51..c3e88a8ee7f3 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -67,12 +67,6 @@ GNU_CONFIGURE= yes
USE_BISON= yes
USE_REINPLACE= yes
-WITH_PTHREAD_LIBS?= ${PTHREAD_LIBS:S/-l//}
-WITH_PTHREAD_CFLAGS?= ${PTHREAD_CFLAGS}
-
-CONFIGURE_ENV= ac_cv_pthreads_lib=${WITH_PTHREAD_LIBS} \
- ac_cv_pthreads_cflags=${WITH_PTHREAD_CFLAGS}
-
CONFIGURE_ARGS= --enable-versioning \
--enable-memory-limit \
--with-layout=GNU \
@@ -541,6 +535,13 @@ CONFIGURE_ARGS+=--with-zlib
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 500016
+WITH_PTHREAD_LIBS?= ${PTHREAD_LIBS:S/-l//}
+WITH_PTHREAD_CFLAGS?= ${PTHREAD_CFLAGS}
+CONFIGURE_ENV= ac_cv_pthreads_lib=${WITH_PTHREAD_LIBS} \
+ ac_cv_pthreads_cflags=${WITH_PTHREAD_CFLAGS}
+.endif
+
.if !defined(WITHOUT_APACHE)
.if exists(${LOCALBASE}/include/apache2/httpd.h)
WITH_APACHE2= yes
diff --git a/lang/php53/Makefile b/lang/php53/Makefile
index 693aecc26b51..c3e88a8ee7f3 100644
--- a/lang/php53/Makefile
+++ b/lang/php53/Makefile
@@ -67,12 +67,6 @@ GNU_CONFIGURE= yes
USE_BISON= yes
USE_REINPLACE= yes
-WITH_PTHREAD_LIBS?= ${PTHREAD_LIBS:S/-l//}
-WITH_PTHREAD_CFLAGS?= ${PTHREAD_CFLAGS}
-
-CONFIGURE_ENV= ac_cv_pthreads_lib=${WITH_PTHREAD_LIBS} \
- ac_cv_pthreads_cflags=${WITH_PTHREAD_CFLAGS}
-
CONFIGURE_ARGS= --enable-versioning \
--enable-memory-limit \
--with-layout=GNU \
@@ -541,6 +535,13 @@ CONFIGURE_ARGS+=--with-zlib
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 500016
+WITH_PTHREAD_LIBS?= ${PTHREAD_LIBS:S/-l//}
+WITH_PTHREAD_CFLAGS?= ${PTHREAD_CFLAGS}
+CONFIGURE_ENV= ac_cv_pthreads_lib=${WITH_PTHREAD_LIBS} \
+ ac_cv_pthreads_cflags=${WITH_PTHREAD_CFLAGS}
+.endif
+
.if !defined(WITHOUT_APACHE)
.if exists(${LOCALBASE}/include/apache2/httpd.h)
WITH_APACHE2= yes