aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2013-12-15 23:18:07 +0800
committerdemon <demon@FreeBSD.org>2013-12-15 23:18:07 +0800
commita76a6b3bbc08e59b950b029e22ab98094737328d (patch)
treeda72493c84f61bfe626d030fcc75270867d8f98f
parent87261f8e6ff426cd621e6c3c6e44f1122299ca12 (diff)
downloadfreebsd-ports-gnome-a76a6b3bbc08e59b950b029e22ab98094737328d.tar.gz
freebsd-ports-gnome-a76a6b3bbc08e59b950b029e22ab98094737328d.tar.zst
freebsd-ports-gnome-a76a6b3bbc08e59b950b029e22ab98094737328d.zip
Add new option: EXTRAOPTS. It enables parsing of plugins ini
config files for extra options. Submitted by: Chris 'sh0shin' Frage <cf@sh0shin.org>
-rw-r--r--net-mgmt/nagios-plugins/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/net-mgmt/nagios-plugins/Makefile b/net-mgmt/nagios-plugins/Makefile
index 5dc0f753294e..c17a646e1166 100644
--- a/net-mgmt/nagios-plugins/Makefile
+++ b/net-mgmt/nagios-plugins/Makefile
@@ -18,8 +18,8 @@ USE_AUTOTOOLS= libtool aclocal autoconf automake
ACLOCAL_ARGS= -I m4 -I gl/m4
AUTOMAKE_ARGS= --add-missing
-OPTIONS_DEFINE= QSTAT FPING NETSNMP RADIUS MYSQL PGSQL LDAP IPV6 JAIL NLS DBI
-OPTIONS_DEFAULT=IPV6
+OPTIONS_DEFINE= QSTAT FPING NETSNMP RADIUS MYSQL PGSQL LDAP IPV6 JAIL NLS DBI EXTRAOPTS
+OPTIONS_DEFAULT=IPV6 EXTRAOPTS
QSTAT_DESC= Game server query support (check_game)
FPING_DESC= Support for non-flooding fast ping (check_fping)
@@ -30,6 +30,7 @@ PGSQL_DESC= PostgreSQL support (check_pgsql)
LDAP_DESC= OpenLDAP support (check_ldap)
JAIL_DESC= Compilation within jail(8) (see Makefile)
DBI_DESC= Check database using DBI
+EXTRAOPTS_DESC= Parsing of plugins ini config files for extra options
GNU_CONFIGURE= yes
@@ -156,6 +157,10 @@ PLIST_SUB+= SUB_DNS="@comment "
PLIST_SUB+= SUB_DNS=""
.endif
+.if ${PORT_OPTIONS:MEXTRAOPTS}
+CONFIGURE_ARGS+= --enable-extra-opts
+.endif
+
post-patch:
.for file in check_by_ssh.c check_disk.c check_http.c check_mrtgtraf.c \
check_nagios.c check_ntp.c check_ntp_peer.c check_ntp_time.c \