aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-12-19 18:20:36 +0800
committerwill <will@FreeBSD.org>2000-12-19 18:20:36 +0800
commita77685d45561e3fc6580003b75741a3afd2842e3 (patch)
tree8cbc9334511b8cde25e956c74feab42e2232403c
parent3281b3fa19d3622f5d5d32d57531396caf87f77a (diff)
downloadfreebsd-ports-gnome-a77685d45561e3fc6580003b75741a3afd2842e3.tar.gz
freebsd-ports-gnome-a77685d45561e3fc6580003b75741a3afd2842e3.tar.zst
freebsd-ports-gnome-a77685d45561e3fc6580003b75741a3afd2842e3.zip
Add ftree 1.6, a tool for displaying family tree genealogy information.
It's a Linux binary. PR: 22997 Submitted by: Kim Scarborough <sluggo@unknown.nu>
-rw-r--r--misc/Makefile1
-rw-r--r--misc/ftree/Makefile54
-rw-r--r--misc/ftree/distinfo1
-rw-r--r--misc/ftree/pkg-comment1
-rw-r--r--misc/ftree/pkg-descr8
-rw-r--r--misc/ftree/pkg-plist6
6 files changed, 71 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 46236c4e2502..2f144045736a 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -57,6 +57,7 @@
SUBDIR += findutils
SUBDIR += fortuneit
SUBDIR += freedialog
+ SUBDIR += ftree
SUBDIR += geekcode
SUBDIR += git
SUBDIR += gnomepm
diff --git a/misc/ftree/Makefile b/misc/ftree/Makefile
new file mode 100644
index 000000000000..f695d7ed50b7
--- /dev/null
+++ b/misc/ftree/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: ftree
+# Date created: 20 November 2000
+# Whom: Kim Scarborough <user@unknown.nu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ftree
+PORTVERSION= 1.6
+CATEGORIES= misc linux
+MASTER_SITES= http://www.vjet.demon.co.uk/ftree/ \
+ http://www.unknown.nu/ports/
+DISTNAME= ftree-1.6-static
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= user@unknown.nu
+
+RUN_DEPENDS= /compat/linux/lib/libc.so.6:${PORTSDIR}/emulators/linux_base
+
+ONLY_FOR_ARCHS= i386
+NO_CDROM= Non-commercial use only
+RESTRICTED= Non-commercial use only
+
+WRKSRC= ${WRKDIR}/usr
+MAN1= ftree.1
+
+STRIP= # empty: do not strip linux binary!
+
+do-patch:
+do-configure:
+do-build:
+ brandelf -t Linux ${WRKSRC}/X11R6/bin/ftree
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/X11R6/bin/ftree ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/X11R6/man/man1/ftree.1 ${PREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/ftree
+ ${MKDIR} ${PREFIX}/share/doc/ftree/examples
+ ${INSTALL_DATA} ${WRKSRC}/doc/ftree-1.6/Copyright\
+ ${PREFIX}/share/doc/ftree
+ ${INSTALL_DATA} ${WRKSRC}/doc/ftree-1.6/ReleaseNotes-1.6.txt\
+ ${PREFIX}/share/doc/ftree
+ ${INSTALL_DATA} ${WRKSRC}/doc/ftree-1.6/examples/royal.ged\
+ ${PREFIX}/share/doc/ftree/examples
+.endif
+
+pre-install:
+ @${ECHO}
+ @${ECHO} "This software is licensed for NON-COMMERCIAL USE only. If you intend"
+ @${ECHO} "to use ftree for any commercial purpose you must contact the author"
+ @${ECHO} "at ftree@vjet.demon.co.uk for a license arrangement."
+ @${ECHO}
+
+.include <bsd.port.mk>
diff --git a/misc/ftree/distinfo b/misc/ftree/distinfo
new file mode 100644
index 000000000000..81d4a4d3e595
--- /dev/null
+++ b/misc/ftree/distinfo
@@ -0,0 +1 @@
+MD5 (ftree-1.6-static.tgz) = 58c7a7c9243d8c18a31a8cc6e93fd52b
diff --git a/misc/ftree/pkg-comment b/misc/ftree/pkg-comment
new file mode 100644
index 000000000000..ec64e8b0f0d5
--- /dev/null
+++ b/misc/ftree/pkg-comment
@@ -0,0 +1 @@
+A program to store and display family tree genealogy information under X
diff --git a/misc/ftree/pkg-descr b/misc/ftree/pkg-descr
new file mode 100644
index 000000000000..6ffae03fd036
--- /dev/null
+++ b/misc/ftree/pkg-descr
@@ -0,0 +1,8 @@
+Ftree is a GUI Linux binary for storing and displaying family tree
+genealogy information. It reads and writes standard GEDCOM 5.5 format
+files.
+
+It is licensed for non-commercial use only.
+
+
+WWW: http://www.vjet.demon.co.uk/ftree/
diff --git a/misc/ftree/pkg-plist b/misc/ftree/pkg-plist
new file mode 100644
index 000000000000..8f527d80f2d1
--- /dev/null
+++ b/misc/ftree/pkg-plist
@@ -0,0 +1,6 @@
+bin/ftree
+share/doc/ftree/Copyright
+share/doc/ftree/ReleaseNotes-1.6.txt
+share/doc/ftree/examples/royal.ged
+@dirrm share/doc/ftree/examples
+@dirrm share/doc/ftree