aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2019-05-20 05:54:06 +0800
committersunpoet <sunpoet@FreeBSD.org>2019-05-20 05:54:06 +0800
commitaf8d335f805967eb67a901b1ecd3abeb727eb69a (patch)
treec8bf15659033428c02ee0d5aea61e6c8e5f27d63
parentd3a67c647b3ced31599f58601e5ed04bcd89033f (diff)
downloadfreebsd-ports-gnome-af8d335f805967eb67a901b1ecd3abeb727eb69a.tar.gz
freebsd-ports-gnome-af8d335f805967eb67a901b1ecd3abeb727eb69a.tar.zst
freebsd-ports-gnome-af8d335f805967eb67a901b1ecd3abeb727eb69a.zip
Add GRAPHITE, INTERPOLATABLE, LXML, PLOT, SYMFONT, UFO, UNICODE and WOFF options for extra dependencies from upstream
-rw-r--r--print/py-fonttools/Makefile39
1 files changed, 38 insertions, 1 deletions
diff --git a/print/py-fonttools/Makefile b/print/py-fonttools/Makefile
index 7377d509c411..982147268041 100644
--- a/print/py-fonttools/Makefile
+++ b/print/py-fonttools/Makefile
@@ -19,4 +19,41 @@ USE_PYTHON= autoplist concurrent distutils
MAKE_ENV= FONTTOOLS_MANPATH="man"
NO_ARCH= yes
-.include <bsd.port.mk>
+OPTIONS_DEFINE= GRAPHITE INTERPOLATABLE LXML PLOT SYMFONT UFO UNICODE WOFF
+GRAPHITE_DESC= Process graphite type tables in ttLib/tables
+INTERPOLATABLE_DESC= Interpolatability support
+LXML_DESC= Read/write XML files via lxml (faster/safer than built-in ElementTree)
+PLOT_DESC= Visualize DesignSpaceDocument and resulting VariationModel
+SYMFONT_DESC= Symbolic font statistics analysis
+UFO_DESC= Read/write UFO fonts
+UNICODE_DESC= Use latest Unicode Character Database
+WOFF_DESC= Compress/uncompress WOFF webfonts
+
+GRAPHITE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lz4>=1.7.4.2:archivers/py-lz4@${PY_FLAVOR}
+INTERPOLATABLE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}scipy>=0:science/py-scipy@${PY_FLAVOR}
+LXML_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>=4.0<5:devel/py-lxml@${PY_FLAVOR}
+PLOT_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}matplotlib>=0:math/py-matplotlib@${PY_FLAVOR}
+SYMFONT_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sympy>=0:math/py-sympy@${PY_FLAVOR}
+UFO_RUN_DEPENDS= ${PY_ENUM34} \
+ ${PYTHON_PKGNAMEPREFIX}fs2>=2.2.0<3:devel/py-fs2@${PY_FLAVOR}
+WOFF_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}brotli>=1.0.1:archivers/py-brotli@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zopfli>=0.1.4:archivers/py-zopfli@${PY_FLAVOR}
+
+.include <bsd.port.pre.mk>
+
+.if ${PORT_OPTIONS:MLXML}
+.if ${PYTHON_REL} < 3400
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}singledispatch>=3.4.0.3:devel/py-singledispatch@${PY_FLAVOR}
+.endif
+.if ${PYTHON_REL} < 3500
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}typing>=0:devel/py-typing@${PY_FLAVOR}
+.endif
+.endif
+
+.if ${PORT_OPTIONS:MUNICODE}
+.if ${PYTHON_REL} < 3700
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}unicodedata2>=11.0.0:devel/py-unicodedata2@${PY_FLAVOR}
+.endif
+.endif
+
+.include <bsd.port.post.mk>