aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2002-11-15 02:42:53 +0800
committermarcus <marcus@FreeBSD.org>2002-11-15 02:42:53 +0800
commitafc4b0c28727d10b432a7c075764536103bc6aad (patch)
tree75003a02fe3f6f1c65ed732d46956e64f22527c0
parentd2d9d70ce2b6cde3a16c9acc73eac95788cea314 (diff)
downloadfreebsd-ports-gnome-afc4b0c28727d10b432a7c075764536103bc6aad.tar.gz
freebsd-ports-gnome-afc4b0c28727d10b432a7c075764536103bc6aad.tar.zst
freebsd-ports-gnome-afc4b0c28727d10b432a7c075764536103bc6aad.zip
Undo the SGML_CATALOG_FILES variable breakage introduced in 2.4.26. This
caused KDE documentation not to build. This patch has been rolled into libxml CVS, and should be resolved in the next release. See http://bugzilla.gnome.org/show_bug.cgi?id=96963 for more details. Submitted by: will Obtained from: libxml CVS
-rw-r--r--textproc/libxml2/Makefile1
-rw-r--r--textproc/libxml2/files/patch-catalog.c26
2 files changed, 25 insertions, 2 deletions
diff --git a/textproc/libxml2/Makefile b/textproc/libxml2/Makefile
index fb5407a93833..c66cf1d013e6 100644
--- a/textproc/libxml2/Makefile
+++ b/textproc/libxml2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libxml2
PORTVERSION= 2.4.26
+PORTREVISION= 1
CATEGORIES= textproc gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.4
diff --git a/textproc/libxml2/files/patch-catalog.c b/textproc/libxml2/files/patch-catalog.c
index a567a2fe728b..5559d9eca6a9 100644
--- a/textproc/libxml2/files/patch-catalog.c
+++ b/textproc/libxml2/files/patch-catalog.c
@@ -1,5 +1,9 @@
---- catalog.c.orig Mon Jun 3 15:28:28 2002
-+++ catalog.c Mon Jun 3 15:29:03 2002
+Note the second chunk in this patch can be removed on the next release. It
+was added to crrect GNOME Bug#96963 which broke the
+SGML_CATALOG_FILES variable.
+
+--- catalog.c.orig Sat Oct 5 04:35:13 2002
++++ catalog.c Thu Nov 14 01:41:06 2002
@@ -56,10 +56,10 @@
#define XML_URN_PUBID "urn:publicid:"
#define XML_CATAL_BREAK ((xmlChar *) -1)
@@ -13,3 +17,21 @@
#endif
static int xmlExpandCatalog(xmlCatalogPtr catal, const char *filename);
+@@ -2938,7 +2938,7 @@
+ while (IS_BLANK(*cur)) cur++;
+ if (*cur != 0) {
+ paths = cur;
+- while ((*cur != 0) && (!IS_BLANK(*cur)))
++ while ((*cur != 0) && (*cur != ':') && (!IS_BLANK(*cur)))
+ cur++;
+ path = xmlStrndup((const xmlChar *)paths, cur - paths);
+ if (path != NULL) {
+@@ -2946,6 +2946,8 @@
+ xmlFree(path);
+ }
+ }
++ while(*cur == ':')
++ cur++;
+ }
+ }
+