aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-02-06 02:58:19 +0800
committerjbeich <jbeich@FreeBSD.org>2017-02-06 02:58:19 +0800
commitb765db6a9dade59025d40eacb2626a1d28b7edc8 (patch)
tree93db38f42d2c0cf677c0b0e4c62a69e137d7fc8f
parent2754ad952713b33599f3a3af0cb8558f21fb1920 (diff)
downloadfreebsd-ports-gnome-b765db6a9dade59025d40eacb2626a1d28b7edc8.tar.gz
freebsd-ports-gnome-b765db6a9dade59025d40eacb2626a1d28b7edc8.tar.zst
freebsd-ports-gnome-b765db6a9dade59025d40eacb2626a1d28b7edc8.zip
devel/kore: unbreak with GCC after r426629
cc1: error: -Werror=c11-extensions: no option -Wc11-extensions PR: 214638 Reported by: marino, pkg-fallout (mips, mips64)
-rw-r--r--devel/kore/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/devel/kore/Makefile b/devel/kore/Makefile
index 73d0a29d90d1..160f109e53b9 100644
--- a/devel/kore/Makefile
+++ b/devel/kore/Makefile
@@ -13,11 +13,13 @@ COMMENT= Web application framework for writing web APIs in C
LICENSE= ISCL
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= gmake
+USES= compiler gmake
USE_GITHUB= yes
GH_ACCOUNT= jorisvink
+CFLAGS+= ${CFLAGS_${CHOSEN_COMPILER_TYPE}}
+CFLAGS_clang= -Wno-error=c11-extensions # 12.0 + -pedantic
MAKE_ARGS= INSTALL_DIR="${STAGEDIR}${PREFIX}/bin" \
INCLUDE_DIR="${STAGEDIR}${PREFIX}/include/kore"
@@ -54,7 +56,6 @@ post-patch:
# FreeBSD 12.0-CURRENT after r308264
@${REINPLACE_CMD} -e 's|CFLAGS+=-O|#|g' \
-e 's|/usr/local/|${LOCALBASE}/|g' \
- -e 's|-pedantic|-pedantic -Wno-error=c11-extensions|g' \
${WRKSRC}/Makefile
pre-install: