aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2011-08-13 00:10:02 +0800
committerlinimon <linimon@FreeBSD.org>2011-08-13 00:10:02 +0800
commitb8260fb5d3de1a826815e82fc9cc20da79746be8 (patch)
tree4fa822f5ca97288e46b78755627835ecbebce6c8
parent4ffdcdbbd3d3f377b9896420baf9baf9cb563061 (diff)
downloadfreebsd-ports-gnome-b8260fb5d3de1a826815e82fc9cc20da79746be8.tar.gz
freebsd-ports-gnome-b8260fb5d3de1a826815e82fc9cc20da79746be8.tar.zst
freebsd-ports-gnome-b8260fb5d3de1a826815e82fc9cc20da79746be8.zip
- fix problem with metadata on tier-2 machines for Pascal ports. The
reason is that bsd.fpc.mk was only defining PPNAME for i386 and amd64. Provide a placeholder and proper IGNORE for tier-2 [1] - remove obsolete check for /usr/share/mk/bsd.port.options.mk [2] - add USE_DRUPAL for easy include of Mk/bsd.drupal.mk [3] PR: ports/155017 [2], ports/159288 [3] Submitted by: linimon (discussed with acm), eadler, crees
-rw-r--r--Mk/bsd.fpc.mk4
-rw-r--r--Mk/bsd.port.mk17
2 files changed, 8 insertions, 13 deletions
diff --git a/Mk/bsd.fpc.mk b/Mk/bsd.fpc.mk
index bf505d01ead4..e0e71f60bd86 100644
--- a/Mk/bsd.fpc.mk
+++ b/Mk/bsd.fpc.mk
@@ -45,6 +45,10 @@ IGNORE= incompatible fpc ${FPC_CURRENT_VER} compiler, please install ${FPC_VER}
PPNAME= ppc386
.elif ${ARCH} == "amd64"
PPNAME= ppcx64
+.else
+PPNAME= ppc_not_yet_ported
+ONLY_FOR_ARCHS= i386 amd64
+ONLY_FOR_ARCHS_REASON= not yet ported to anything other than i386 and amd64
.endif
BUILD_DEPENDS+= ${PPNAME}:${PORTSDIR}/lang/fpc
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 92cb21806d12..dd288ca11eeb 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1549,6 +1549,10 @@ PERL= ${LOCALBASE}/bin/perl
.include "${PORTSDIR}/Mk/bsd.qt.mk"
.endif
+.if defined(USE_DRUPAL)
+.include "${PORTSDIR}/Mk/bsd.drupal.mk"
+.endif
+
.if defined(WANT_GECKO) || defined(USE_GECKO) || defined(USE_FIREFOX) || defined(USE_FIREFOX_BUILD) || defined(USE_SEAMONKEY) || defined(USE_SEAMONKEY_BUILD) || defined(USE_THUNDERBIRD) || defined(USE_THUNDERBIRD_BUILD)
.include "${PORTSDIR}/Mk/bsd.gecko.mk"
.endif
@@ -2932,19 +2936,6 @@ maintainer:
.if !target(check-makefile)
check-makefile::
-.if !exists(/usr/share/mk/bsd.port.options.mk)
- @${ECHO_CMD} "!!! Detected system without bsd.port.options.mk (probably old FreeBSD version)"
- @${ECHO_CMD} "!!! Dropping bsd.port.options.mk into /usr/share/mk"
- -@${ECHO_CMD} "USEOPTIONSMK= yes" > /usr/share/mk/bsd.port.options.mk 2>/dev/null
- -@${ECHO_CMD} "INOPTIONSMK= yes" >> /usr/share/mk/bsd.port.options.mk 2>/dev/null
- -@${ECHO_CMD} ".include <bsd.port.mk>" >> /usr/share/mk/bsd.port.options.mk 2>/dev/null
- -@${ECHO_CMD} ".undef INOPTIONSMK" >> /usr/share/mk/bsd.port.options.mk 2>/dev/null
-.if exists(/usr/share/mk/bsd.port.options.mk)
- @${ECHO_CMD} "!!! Done"
-.else
- @${ECHO_CMD} "!!! Failed"
-.endif
-.endif
@${DO_NADA}
.endif