aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-12-16 08:04:50 +0800
committerbapt <bapt@FreeBSD.org>2013-12-16 08:04:50 +0800
commitb8522cdec75ca47f301c29c1af1a20554e962031 (patch)
tree4cc8ee5e8dc56a47e507a5d478909445343f2613
parentd00e7d7b4660842dc48bf65a7cbbaa5572b34551 (diff)
downloadfreebsd-ports-gnome-b8522cdec75ca47f301c29c1af1a20554e962031.tar.gz
freebsd-ports-gnome-b8522cdec75ca47f301c29c1af1a20554e962031.tar.zst
freebsd-ports-gnome-b8522cdec75ca47f301c29c1af1a20554e962031.zip
Support stage
Fix build on head Respect CXXFLAGS
-rw-r--r--devel/loki/Makefile21
-rw-r--r--devel/loki/pkg-descr1
2 files changed, 13 insertions, 9 deletions
diff --git a/devel/loki/Makefile b/devel/loki/Makefile
index 56ac2953d694..c7b5dfe103a3 100644
--- a/devel/loki/Makefile
+++ b/devel/loki/Makefile
@@ -7,24 +7,29 @@ CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}-lib/Loki/Loki%20${PORTVERSION}
MAINTAINER= snnn119@gmail.com
-COMMENT= A C++ library of common design patterns
+COMMENT= C++ library of common design patterns
-USE_DOS2UNIX= yes
-USE_GMAKE= yes
+USES= gmake dos2unix
USE_LDCONFIG= yes
+CXXFLAGS+= -Wno-return-type
+
DOCS= README CHANGES doc/flex/flex_string.html \
doc/yasli/Notes.txt \
doc/yasli/yasli.html
-NO_STAGE= yes
+post-patch:
+ @${REINPLACE_CMD} 's/bad_function_call/Loki::bad_function_call/g' \
+ ${WRKSRC}/test/Function/FunctionTest.cpp
+ @${REINPLACE_CMD} -e '/CXXWARNFLAGS/s/$$/ ${CXXFLAGS}/g' \
+ -e 's/\$${PREFIX}/$${DESTDIR}$${PREFIX}/g' \
+ ${WRKSRC}/Makefile.common
+
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in ${DOCS}
- ${INSTALL_MAN} ${WRKSRC}/${i} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.pre.mk>
diff --git a/devel/loki/pkg-descr b/devel/loki/pkg-descr
index 1c23aea80175..e64b3642bea5 100644
--- a/devel/loki/pkg-descr
+++ b/devel/loki/pkg-descr
@@ -1,5 +1,4 @@
A C++ library of designs, containing flexible implementations of
common design patterns and idioms.
-
WWW: http://sourceforge.net/projects/loki-lib/