aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2013-03-19 19:03:57 +0800
committerkwm <kwm@FreeBSD.org>2013-03-19 19:03:57 +0800
commitb9a34c2f06d05cc0b73bbd9402efc910da0b1ad5 (patch)
treec53cc47ef50c9f9f66354ca7913c683ff72a1fe5
parent9395fa65d529fafecacf971baaf388df5f64becc (diff)
downloadfreebsd-ports-gnome-b9a34c2f06d05cc0b73bbd9402efc910da0b1ad5.tar.gz
freebsd-ports-gnome-b9a34c2f06d05cc0b73bbd9402efc910da0b1ad5.tar.zst
freebsd-ports-gnome-b9a34c2f06d05cc0b73bbd9402efc910da0b1ad5.zip
balsa: add back pre.mk and post.mk seem to fix the failure
gnome-applets: move the pre.mk up to include the ARCH test. Submitted by: freshports sanity check
-rw-r--r--mail/balsa/Makefile4
-rw-r--r--x11/gnome-applets/Makefile5
2 files changed, 6 insertions, 3 deletions
diff --git a/mail/balsa/Makefile b/mail/balsa/Makefile
index a0fa6caba465..8c40b60b9f81 100644
--- a/mail/balsa/Makefile
+++ b/mail/balsa/Makefile
@@ -77,6 +77,8 @@ CONFIGURE_ARGS+=--with-libnotify=yes
CONFIGURE_ARGS+=--with-libnotify=no
.endif
+.include <bsd.port.pre.mk>
+
.if ${PREFIX}==${LOCALBASE}
PLIST_SUB+= GTKICON="@comment "
.else
@@ -93,4 +95,4 @@ post-patch:
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
's|-D.*_DISABLE_DEPRECATED_SOURCE||g ; s|-D.*_DISABLE_DEPRECATED||g'
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11/gnome-applets/Makefile b/x11/gnome-applets/Makefile
index 534a88ddbd08..b31397639bd5 100644
--- a/x11/gnome-applets/Makefile
+++ b/x11/gnome-applets/Makefile
@@ -30,6 +30,7 @@ INSTALLS_ICONS= yes
USE_LDCONFIG= yes
USES= pathfix
USE_GNOME= gnomeprefix intlhack gnomepanel gnomedocutils libgnomekbd
+WANT_GNOME= yes
USE_GSTREAMER= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-mixer-applet \
@@ -59,6 +60,8 @@ PLIST_SUB+= COMMANDER="" OLDCOMMANDER="@comment "
PLIST_SUB+= COMMANDER="@comment " OLDCOMMANDER=""
.endif
+.include <bsd.port.pre.mk>
+
.if ( exists(${pygnomedesktop_DETECT}) ) || \
( ( ${HAVE_GNOME:Mpygnomedesktop}!="" ) && ${ARCH}!="sparc64" )
USE_PYTHON= yes
@@ -69,8 +72,6 @@ PLIST_SUB+= PYTHON=""
PLIST_SUB+= PYTHON="@comment "
.endif
-.include <bsd.port.pre.mk>
-
.if ${ARCH} != "i386" && ${ARCH} != "amd64"
CFLAGS+= -fPIC
PLIST_SUB= BATTERY="@comment "