aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2005-11-18 02:37:38 +0800
committermnag <mnag@FreeBSD.org>2005-11-18 02:37:38 +0800
commitbde92dff17662c79a721cf64b49d56a87a352dce (patch)
tree24bd3108614e0a33e39b74a94337ec6779cc11b4
parentb35e7e88d2323cc3004ef85719d9012379f02fc6 (diff)
downloadfreebsd-ports-gnome-bde92dff17662c79a721cf64b49d56a87a352dce.tar.gz
freebsd-ports-gnome-bde92dff17662c79a721cf64b49d56a87a352dce.tar.zst
freebsd-ports-gnome-bde92dff17662c79a721cf64b49d56a87a352dce.zip
Fix path to /usr/bin/mail
Bump PORTREVISION PR: 89192 Noticed by: Frank Steinborn Approved by: Xavier Beaudouin <kiwi@oav.net> (maintainer)
-rw-r--r--www/mod_dosevasive20/Makefile7
-rw-r--r--www/mod_evasive/Makefile7
-rw-r--r--www/mod_evasive20/Makefile7
3 files changed, 21 insertions, 0 deletions
diff --git a/www/mod_dosevasive20/Makefile b/www/mod_dosevasive20/Makefile
index a2a32af908a7..4b6a844c3871 100644
--- a/www/mod_dosevasive20/Makefile
+++ b/www/mod_dosevasive20/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mod_dosevasive20
PORTVERSION= 1.10
+PORTREVISION= 1
CATEGORIES= www security
MASTER_SITES= http://www.nuclearelephant.com/projects/dosevasive/ \
ftp://ftp.oav.net/pkg_freebsd/distfiles/
@@ -18,6 +19,7 @@ COMMENT= An Apache 2 module to try to protect HTTP DoS or DDoS attacks
WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_REINPLACE= yes
WANT_APACHE= 2
AP_FAST_BUILD= YES
AP_GENPLIST= YES
@@ -28,6 +30,11 @@ PORTDOCS= LICENSE README test.pl
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/www/apache2/Makefile.modules.3rd"
+post-patch:
+ @${REINPLACE_CMD} -e "s|/bin/mail|/usr/bin/mail|g" \
+ ${WRKSRC}/mod_dosevasive.c ${WRKSRC}/mod_dosevasive20.c \
+ ${WRKSRC}/mod_dosevasiveNSAPI.c
+
post-install:
.if !defined (NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/www/mod_evasive/Makefile b/www/mod_evasive/Makefile
index a2a32af908a7..4b6a844c3871 100644
--- a/www/mod_evasive/Makefile
+++ b/www/mod_evasive/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mod_dosevasive20
PORTVERSION= 1.10
+PORTREVISION= 1
CATEGORIES= www security
MASTER_SITES= http://www.nuclearelephant.com/projects/dosevasive/ \
ftp://ftp.oav.net/pkg_freebsd/distfiles/
@@ -18,6 +19,7 @@ COMMENT= An Apache 2 module to try to protect HTTP DoS or DDoS attacks
WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_REINPLACE= yes
WANT_APACHE= 2
AP_FAST_BUILD= YES
AP_GENPLIST= YES
@@ -28,6 +30,11 @@ PORTDOCS= LICENSE README test.pl
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/www/apache2/Makefile.modules.3rd"
+post-patch:
+ @${REINPLACE_CMD} -e "s|/bin/mail|/usr/bin/mail|g" \
+ ${WRKSRC}/mod_dosevasive.c ${WRKSRC}/mod_dosevasive20.c \
+ ${WRKSRC}/mod_dosevasiveNSAPI.c
+
post-install:
.if !defined (NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/www/mod_evasive20/Makefile b/www/mod_evasive20/Makefile
index a2a32af908a7..4b6a844c3871 100644
--- a/www/mod_evasive20/Makefile
+++ b/www/mod_evasive20/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mod_dosevasive20
PORTVERSION= 1.10
+PORTREVISION= 1
CATEGORIES= www security
MASTER_SITES= http://www.nuclearelephant.com/projects/dosevasive/ \
ftp://ftp.oav.net/pkg_freebsd/distfiles/
@@ -18,6 +19,7 @@ COMMENT= An Apache 2 module to try to protect HTTP DoS or DDoS attacks
WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_REINPLACE= yes
WANT_APACHE= 2
AP_FAST_BUILD= YES
AP_GENPLIST= YES
@@ -28,6 +30,11 @@ PORTDOCS= LICENSE README test.pl
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/www/apache2/Makefile.modules.3rd"
+post-patch:
+ @${REINPLACE_CMD} -e "s|/bin/mail|/usr/bin/mail|g" \
+ ${WRKSRC}/mod_dosevasive.c ${WRKSRC}/mod_dosevasive20.c \
+ ${WRKSRC}/mod_dosevasiveNSAPI.c
+
post-install:
.if !defined (NOPORTDOCS)
@${MKDIR} ${DOCSDIR}