aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2019-08-26 02:05:07 +0800
committersunpoet <sunpoet@FreeBSD.org>2019-08-26 02:05:07 +0800
commitbe6e8cde6b679433dd34a2ba548e57e2b65feac9 (patch)
tree39d48b12439eea38d63ae75d69e3732b8cd8d3ff
parent0ba8f12d897527d0d11c3aabef393c1eff0e096b (diff)
downloadfreebsd-ports-gnome-be6e8cde6b679433dd34a2ba548e57e2b65feac9.tar.gz
freebsd-ports-gnome-be6e8cde6b679433dd34a2ba548e57e2b65feac9.tar.zst
freebsd-ports-gnome-be6e8cde6b679433dd34a2ba548e57e2b65feac9.zip
Add rubygem-rails-dom-testing-rails52 2.0.3 (copied from rubygem-rails-dom-testing-rails5)
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/rubygem-rails-dom-testing-rails52/Makefile24
-rw-r--r--textproc/rubygem-rails-dom-testing-rails52/distinfo3
-rw-r--r--textproc/rubygem-rails-dom-testing-rails52/pkg-descr8
4 files changed, 36 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 592bf7afdc58..07cfc636fee3 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1589,6 +1589,7 @@
SUBDIR += rubygem-rails-dom-testing
SUBDIR += rubygem-rails-dom-testing-rails5
SUBDIR += rubygem-rails-dom-testing-rails50
+ SUBDIR += rubygem-rails-dom-testing-rails52
SUBDIR += rubygem-rails-dom-testing1
SUBDIR += rubygem-rails-html-sanitizer
SUBDIR += rubygem-rak
diff --git a/textproc/rubygem-rails-dom-testing-rails52/Makefile b/textproc/rubygem-rails-dom-testing-rails52/Makefile
new file mode 100644
index 000000000000..9aa8c59c5833
--- /dev/null
+++ b/textproc/rubygem-rails-dom-testing-rails52/Makefile
@@ -0,0 +1,24 @@
+# Created by: Johannes Jost Meixner <xmj@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= rails-dom-testing
+PORTVERSION= 2.0.3
+CATEGORIES= textproc rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= -rails52
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Analyse and compare DOMs using Nokogiri
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/MIT-LICENSE
+
+RUN_DEPENDS= rubygem-activesupport52>=4.2.0:devel/rubygem-activesupport52 \
+ rubygem-nokogiri>=1.6:textproc/rubygem-nokogiri
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/rubygem-rails-dom-testing-rails52/distinfo b/textproc/rubygem-rails-dom-testing-rails52/distinfo
new file mode 100644
index 000000000000..d87274f660df
--- /dev/null
+++ b/textproc/rubygem-rails-dom-testing-rails52/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1494610306
+SHA256 (rubygem/rails-dom-testing-2.0.3.gem) = b140c4f39f6e609c8113137b9a60dfc2ecb89864e496f87f23a68b3b8f12d8d1
+SIZE (rubygem/rails-dom-testing-2.0.3.gem) = 14336
diff --git a/textproc/rubygem-rails-dom-testing-rails52/pkg-descr b/textproc/rubygem-rails-dom-testing-rails52/pkg-descr
new file mode 100644
index 000000000000..c87a1ba37065
--- /dev/null
+++ b/textproc/rubygem-rails-dom-testing-rails52/pkg-descr
@@ -0,0 +1,8 @@
+This gem is responsible for comparing HTML doms and asserting that DOM elements
+are present in Rails applications. Doms are compared via assert_dom_equal and
+assert_dom_not_equal. Elements are asserted via assert_select,
+assert_select_encoded, assert_select_email and a subset of the dom can be
+selected with css_select. The gem is developed for Rails 4.2 and above, and
+will not work on previous versions.
+
+WWW: https://github.com/rails/rails-dom-testing