aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2014-06-10 07:29:50 +0800
committermi <mi@FreeBSD.org>2014-06-10 07:29:50 +0800
commitc247098521dd29b7fc60fc185da49805bee1d503 (patch)
tree9de78fffe99910ebae95eb52247a49c29df9fb0a
parentd82269ad0096fc8422fc62e4576a283ab4c3ac14 (diff)
downloadfreebsd-ports-gnome-c247098521dd29b7fc60fc185da49805bee1d503.tar.gz
freebsd-ports-gnome-c247098521dd29b7fc60fc185da49805bee1d503.tar.zst
freebsd-ports-gnome-c247098521dd29b7fc60fc185da49805bee1d503.zip
Support staging.
-rw-r--r--textproc/wordnet/Makefile13
-rw-r--r--textproc/wordnet/files/dict.Makefile2
-rw-r--r--textproc/wordnet/files/include.Makefile2
-rw-r--r--textproc/wordnet/files/src.wnb.Makefile10
-rw-r--r--textproc/wordnet/pkg-plist22
-rw-r--r--textproc/wordnet/scripts/configure2
6 files changed, 33 insertions, 18 deletions
diff --git a/textproc/wordnet/Makefile b/textproc/wordnet/Makefile
index 05a6944449d2..cf61ea64e072 100644
--- a/textproc/wordnet/Makefile
+++ b/textproc/wordnet/Makefile
@@ -10,9 +10,9 @@ MASTER_SITES= http://wordnetcode.princeton.edu/${PORTVERSION}/
MAINTAINER= mi@aldan.algebra.com
COMMENT= Dictionaries and thesauri with devel. libraries (C, TCL) and browsers
-USES= tcl
+USES= tcl uidfix
SCRIPTS_ENV+= TCL_DVER=${TCL_VER} VER=${PORTVERSION}
-MAKE_ENV+= TCL_DVER=${TCL_VER} VER=${PORTVERSION}
+MAKE_ENV+= TCL_DVER=${TCL_VER} VER=${PORTVERSION} STAGEDIR="${STAGEDIR}"
PLIST_SUB+= TCL_DVER=${TCL_VER} VER=${PORTVERSION}
USE_BZIP2= yes
REINPLACE_ARGS= -i ""
@@ -20,7 +20,6 @@ USE_LDCONFIG= yes
SUB_FILES= pkg-message
SUB_LIST+= TCL_VER=${TCL_VER}
-NO_STAGE= yes
post-patch:
${REINPLACE_CMD} -e 's,/usr/local/WordNet-2.1,${DATADIR},g' \
${WRKSRC}/src/wnb ${WRKSRC}/doc/man/*.?
@@ -29,10 +28,4 @@ post-patch:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.pre.mk>
-
-.for s in 1 3 5 7
-MAN$s != ${MAKE} -f ${FILESDIR}/man.Makefile -V MAN$s
-.endfor
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/wordnet/files/dict.Makefile b/textproc/wordnet/files/dict.Makefile
index 39ef1eb1232f..d3a90099cd7e 100644
--- a/textproc/wordnet/files/dict.Makefile
+++ b/textproc/wordnet/files/dict.Makefile
@@ -1,4 +1,4 @@
-WN_INSTALLDIR= ${PREFIX}/share/WordNet
+WN_INSTALLDIR= ${STAGEDIR}${PREFIX}/share/WordNet
WN_FILES= adj.exc adv.exc cntlist cntlist.rev data.adj \
data.adv data.noun data.verb frames.vrb index.adj \
index.adv index.noun index.sense index.verb \
diff --git a/textproc/wordnet/files/include.Makefile b/textproc/wordnet/files/include.Makefile
index 64139eab30d8..60db6be9bbaa 100644
--- a/textproc/wordnet/files/include.Makefile
+++ b/textproc/wordnet/files/include.Makefile
@@ -1,4 +1,4 @@
-WN_INSTALLDIR = ${PREFIX}/include/WordNet
+WN_INSTALLDIR = ${STAGEDIR}${PREFIX}/include/WordNet
WN_FILES= wn.h wngrind.h
diff --git a/textproc/wordnet/files/src.wnb.Makefile b/textproc/wordnet/files/src.wnb.Makefile
index 1f65b17400f4..63998a4d0456 100644
--- a/textproc/wordnet/files/src.wnb.Makefile
+++ b/textproc/wordnet/files/src.wnb.Makefile
@@ -23,14 +23,14 @@ pkgIndex.tcl:
> pkgIndex.tcl
LIBDIR= ${PREFIX}/lib
-RESDIR= ${PREFIX}/share/WordNet/
+RESDIR= ${STAGEDIR}${PREFIX}/share/WordNet/
-${LIBDIR} ${RESDIR} ${LIBDIR}/tcl${TCL_DVER}/Wordnet:
+${LIBDIR} ${RESDIR} ${STAGEDIR}${LIBDIR}/tcl${TCL_DVER}/Wordnet:
mkdir -p ${.TARGET}
-beforeinstall: ${LIBDIR} ${RESDIR} ${LIBDIR}/tcl${TCL_DVER}/Wordnet
- ${BSD_INSTALL_DATA} pkgIndex.tcl ${LIBDIR}/tcl${TCL_DVER}/Wordnet
+beforeinstall: ${RESDIR} ${STAGEDIR}${LIBDIR}/tcl${TCL_DVER}/Wordnet
+ ${BSD_INSTALL_DATA} pkgIndex.tcl ${STAGEDIR}${LIBDIR}/tcl${TCL_DVER}/Wordnet
${BSD_INSTALL_DATA} ${.CURDIR}/*.xbm ${RESDIR}
- ${BSD_INSTALL_SCRIPT} ${.CURDIR:H:H}/src/wnb ${PREFIX}/bin
+ ${BSD_INSTALL_SCRIPT} ${.CURDIR:H:H}/src/wnb ${STAGEDIR}${PREFIX}/bin
.include <bsd.lib.mk>
diff --git a/textproc/wordnet/pkg-plist b/textproc/wordnet/pkg-plist
index be5e399cb17a..99131c583334 100644
--- a/textproc/wordnet/pkg-plist
+++ b/textproc/wordnet/pkg-plist
@@ -31,3 +31,25 @@ lib/tcl%%TCL_DVER%%/Wordnet/pkgIndex.tcl
@dirrm include/WordNet
@dirrm lib/tcl%%TCL_DVER%%/Wordnet
@dirrm %%DATADIR%%
+man/man1/wn.1.gz
+man/man1/wnb.1.gz
+man/man1/wnintro.1.gz
+man/man3/binsrch.3.gz
+man/man3/morph.3.gz
+man/man3/wnintro.3.gz
+man/man3/wnsearch.3.gz
+man/man3/wnutil.3.gz
+man/man5/cntlist.5.gz
+man/man5/lexnames.5.gz
+man/man5/senseidx.5.gz
+man/man5/wndb.5.gz
+man/man5/wninput.5.gz
+man/man5/wnintro.5.gz
+man/man7/morphy.7.gz
+man/man7/uniqbeg.7.gz
+man/man7/wngloss.7.gz
+man/man7/wngroups.7.gz
+man/man7/wnintro.7.gz
+man/man7/wnlicens.7.gz
+man/man7/wnpkgs.7.gz
+man/man7/wnstats.7.gz
diff --git a/textproc/wordnet/scripts/configure b/textproc/wordnet/scripts/configure
index 297a996aa8a7..adeb59e711c2 100644
--- a/textproc/wordnet/scripts/configure
+++ b/textproc/wordnet/scripts/configure
@@ -18,7 +18,7 @@ for mf in ${FILESDIR}/*Makefile ; do \
dir=${WRKSRC}/$dir
test -f ${dir}Makefile.orig && continue
test -f ${dir}Makefile && mv ${dir}Makefile ${dir}Makefile.orig
- cp -p $mf ${dir}Makefile
+ ln -s $mf ${dir}Makefile
done
patch -d ${WRKSRC}/src -p << EOPATCH