aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-05-16 02:33:48 +0800
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-05-16 02:33:48 +0800
commitc81fa62863f6365f24e8b87555aadbf96f979031 (patch)
treee34407d4f378869137db9e8ba40f82f965d7787e
parent39d3c272d9a019685b1ef0ca3b933cc301295898 (diff)
downloadfreebsd-ports-gnome-c81fa62863f6365f24e8b87555aadbf96f979031.tar.gz
freebsd-ports-gnome-c81fa62863f6365f24e8b87555aadbf96f979031.tar.zst
freebsd-ports-gnome-c81fa62863f6365f24e8b87555aadbf96f979031.zip
Add py3-click-threading 0.4.2
- While I'm here, fix indent PR: 219233 Submitted by: Rudolf Siegel <rs.os@t-online.de> Approved by: Christian Geier <geier@lostpackets.de> (maintainer)
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-click-threading/Makefile6
-rw-r--r--devel/py3-click-threading/Makefile12
3 files changed, 16 insertions, 3 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4f4e2bad658f..411e5ecb15a6 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4926,6 +4926,7 @@
SUBDIR += py3-babel
SUBDIR += py3-click
SUBDIR += py3-click-log
+ SUBDIR += py3-click-threading
SUBDIR += py3-colorama
SUBDIR += py3-dbus
SUBDIR += py3-defusedxml
diff --git a/devel/py-click-threading/Makefile b/devel/py-click-threading/Makefile
index 56840dd3ace2..7d9969f30d12 100644
--- a/devel/py-click-threading/Makefile
+++ b/devel/py-click-threading/Makefile
@@ -12,11 +12,11 @@ COMMENT= Multithreaded Click apps made easy
LICENSE= MIT
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>0:devel/py-click
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest \
+RUN_DEPENDS?= ${PYTHON_PKGNAMEPREFIX}click>0:devel/py-click
+TEST_DEPENDS?= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest \
${RUN_DEPENDS}
-USES= python
+USES?= python
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/devel/py3-click-threading/Makefile b/devel/py3-click-threading/Makefile
new file mode 100644
index 000000000000..40a94034401c
--- /dev/null
+++ b/devel/py3-click-threading/Makefile
@@ -0,0 +1,12 @@
+# Created by: rs.os
+# $FreeBSD$
+
+MASTERDIR= ${.CURDIR}/../py-click-threading
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>0:devel/py3-click
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py3-pytest \
+ ${RUN_DEPENDS}
+
+USES= python:3.3+
+
+.include "${MASTERDIR}/Makefile"