aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2014-07-23 03:01:20 +0800
committerdanilo <danilo@FreeBSD.org>2014-07-23 03:01:20 +0800
commitca0451ed7fb13218789f0a0c079e623a7ff2337f (patch)
treeeb9c47b1a471dcdb18b3ae5a0e783e9e38b98077
parent6dd309f835d40ed0f1ed073cda9c6cc13e5bbf74 (diff)
downloadfreebsd-ports-gnome-ca0451ed7fb13218789f0a0c079e623a7ff2337f.tar.gz
freebsd-ports-gnome-ca0451ed7fb13218789f0a0c079e623a7ff2337f.tar.zst
freebsd-ports-gnome-ca0451ed7fb13218789f0a0c079e623a7ff2337f.zip
- Don't strip the binary. This breaks the binary checksumming
- Introduce ADMIN variable PR: ports/192039 Submitted by: Martin Birgmeier <la5lbtyi@aon.at>
-rw-r--r--net/delegate/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/net/delegate/Makefile b/net/delegate/Makefile
index 004febfc1990..868358dfea2a 100644
--- a/net/delegate/Makefile
+++ b/net/delegate/Makefile
@@ -3,6 +3,7 @@
PORTNAME= delegate
PORTVERSION= 9.9.10
+PORTREVISION= 1
CATEGORIES= net www
MASTER_SITES= ftp://ftp.delegate.org/pub/DeleGate/
DISTNAME= ${PORTNAME}${PORTVERSION}
@@ -13,21 +14,21 @@ COMMENT= General purpose TCP/IP proxy system
USES= gmake
SUB_FILES= pkg-message
+ADMIN?= admin@example.com
+
PLIST_FILES= sbin/delegated etc/rc.d/delegated.sh-dist
PORTDOCS= CHANGES COPYRIGHT DG9note.html HowToDG.html IPv6NOTE.txt \
Manual.htm jpconv.htm tutor-en.htm tutor-jp.htm
+# Strip breaks binary checksumming
+STRIP=
+
post-extract:
@${LN} ${WRKSRC}/CHANGES ${WRKSRC}/COPYRIGHT ${WRKSRC}/DG9note.html \
${WRKSRC}/IPv6NOTE.txt ${WRKSRC}/doc
post-patch:
-# Prevent "filesystem was touched prior to 'make install' phase" warning;
-# allow unattended (non-interactive) builds
- @${REINPLACE_CMD} -e 's,"$$(XDG)",& DGROOT=${WRKDIR},' \
- ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -E '/ADMIN/s,undef,admin@example.com, ; \
- s,-F(esign|ver),& DGROOT=${WRKDIR},' ${WRKSRC}/src/Makefile
+ @${REINPLACE_CMD} -E "/ADMIN/s,undef,${ADMIN}," ${WRKSRC}/src/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/delegated ${STAGEDIR}${PREFIX}/sbin