aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2014-07-23 13:19:07 +0800
committerpi <pi@FreeBSD.org>2014-07-23 13:19:07 +0800
commitcff7eefb0c42edb38a84e77d38098a7ba2f05a7f (patch)
tree55735564f89749ca3d0fd3e40b0b959ce44163de
parenta5e4fd3c7cb3e1fafba4eb09ae8495ed9a57df58 (diff)
downloadfreebsd-ports-gnome-cff7eefb0c42edb38a84e77d38098a7ba2f05a7f.tar.gz
freebsd-ports-gnome-cff7eefb0c42edb38a84e77d38098a7ba2f05a7f.tar.zst
freebsd-ports-gnome-cff7eefb0c42edb38a84e77d38098a7ba2f05a7f.zip
www/p5-libapreq2: reduce/fix dependencies
PR: 191161 Submitted by: vivek@khera.org
-rw-r--r--www/p5-libapreq2/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/www/p5-libapreq2/Makefile b/www/p5-libapreq2/Makefile
index 222a281e0091..3ee2ec4a9227 100644
--- a/www/p5-libapreq2/Makefile
+++ b/www/p5-libapreq2/Makefile
@@ -16,7 +16,7 @@ LICENSE= APACHE20
USES= gmake libtool perl5
USE_APACHE= 22+
-USE_PERL5= fixpacklist
+USE_PERL5= fixpacklist run
USE_LDCONFIG= yes
USE_AUTOTOOLS= autoconf
CONFIGURE_ARGS+= --with-apache2-apxs=${APXS} \
@@ -25,12 +25,14 @@ CONFIGURE_ARGS+= --with-apache2-apxs=${APXS} \
MAKE_ENV+= MAKE=${GMAKE} ## MakeMaker blows it without this
-BUILD_DEPENDS+= libapreq2>0:${PORTSDIR}/www/libapreq2 \
+BUILD_DEPENDS= libapreq2>0:${PORTSDIR}/www/libapreq2 \
${APACHE_PKGNAMEPREFIX}mod_perl2>=0:${PORTSDIR}/www/mod_perl2 \
p5-ExtUtils-XSBuilder>=0:${PORTSDIR}/devel/p5-ExtUtils-XSBuilder \
p5-Parse-RecDescent>=0:${PORTSDIR}/devel/p5-Parse-RecDescent
-RUN_DEPENDS+= ${BUILD_DEPENDS}
+RUN_DEPENDS= libapreq2>0:${PORTSDIR}/www/libapreq2 \
+ ${APACHE_PKGNAMEPREFIX}mod_perl2>=0:${PORTSDIR}/www/mod_perl2 \
+ p5-Parse-RecDescent>=0:${PORTSDIR}/devel/p5-Parse-RecDescent
post-patch:
@${REINPLACE_CMD} -i '' -e "s!%%APACHEINCLUDEDIR%%!${APACHEINCLUDEDIR}!" \