aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-04-16 19:16:16 +0800
committermiwi <miwi@FreeBSD.org>2007-04-16 19:16:16 +0800
commitda5251a563a9db31691fa77c56605bee280027db (patch)
tree99b5321741a0374b2f68c06cece9bf8e3fc5fe62
parenteb50a08e6a14ebe255e59dd048b96766cb55feac (diff)
downloadfreebsd-ports-gnome-da5251a563a9db31691fa77c56605bee280027db.tar.gz
freebsd-ports-gnome-da5251a563a9db31691fa77c56605bee280027db.tar.zst
freebsd-ports-gnome-da5251a563a9db31691fa77c56605bee280027db.zip
Smart Cache Loader is most configurable web batch downloader in world! If you
have a very specific needs to grab some portions of web site -- this is right tool for you! This program can be also used as web crawler if you need to crawl defined parts of www site(s). WWW: http://scloader.sourceforge.net/ PR: ports/111595 Submitted by: Radim Kolar <hsn at sanatana.dharma>
-rw-r--r--www/Makefile1
-rw-r--r--www/scloader/Makefile49
-rw-r--r--www/scloader/distinfo3
-rw-r--r--www/scloader/files/scloader.sh3
-rw-r--r--www/scloader/pkg-descr7
5 files changed, 63 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index cdf13c1fb83a..28652eeff971 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1069,6 +1069,7 @@
SUBDIR += sams
SUBDIR += sarg
SUBDIR += sbox-dtc
+ SUBDIR += scloader
SUBDIR += scout
SUBDIR += screem
SUBDIR += script4rss
diff --git a/www/scloader/Makefile b/www/scloader/Makefile
new file mode 100644
index 000000000000..c75166b6cc5e
--- /dev/null
+++ b/www/scloader/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: scloader
+# Date created: 2007-04-13
+# Whom: Radim Kolar <hsn@sanatana.dharma>
+#
+# $FreeBSD$
+#
+
+PORTNAME= scloader
+PORTVERSION= 0.28
+#PORTREVISION= 0
+CATEGORIES= www java
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= loader${PORTVERSION:C/\.//}
+
+MAINTAINER= hsn@sendmail.cz
+COMMENT= Configurable web graber
+
+USE_ZIP= yes
+USE_JAVA= yes
+USE_DOS2UNIX= yes
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/${PORTNAME} %%JAVAJARDIR%%/scloader.jar
+PORTDOCS= README history todo
+
+DOS2UNIX_REGEX= .+\.[^j][^a][^r]$
+
+do-configure:
+ ${SED} -e "s|%%JAVA%%|${LOCALBASE}/bin/java|" \
+ -e "s|%%JAVAJARDIR%%|${JAVAJARDIR}|" \
+ ${FILESDIR}/${PORTNAME}.sh > ${WRKDIR}/${PORTNAME}
+
+do-install:
+ ${INSTALL} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/scloader.jar ${JAVAJARDIR}
+.ifndef NOPORTDOCS
+ ${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+ ${INSTALL_DATA} ${WRKSRC}/doc/manual.html ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/samples/loader.cnf ${DOCSDIR}
+PORTDOCS+= manual.html loader.cnf
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/scloader/distinfo b/www/scloader/distinfo
new file mode 100644
index 000000000000..954e2e1d8c3a
--- /dev/null
+++ b/www/scloader/distinfo
@@ -0,0 +1,3 @@
+MD5 (loader028.zip) = 417ff719bc85fba3d35d453c236ee869
+SHA256 (loader028.zip) = 34c1a99e1ba31e38a8a40595c6ddf26835121a63d3e9a5caa819051ca3af5956
+SIZE (loader028.zip) = 104481
diff --git a/www/scloader/files/scloader.sh b/www/scloader/files/scloader.sh
new file mode 100644
index 000000000000..d5b1e1d292a0
--- /dev/null
+++ b/www/scloader/files/scloader.sh
@@ -0,0 +1,3 @@
+#! /bin/sh
+
+exec "%%JAVA%%" -jar "%%JAVAJARDIR%%/scloader.jar" $@
diff --git a/www/scloader/pkg-descr b/www/scloader/pkg-descr
new file mode 100644
index 000000000000..37d40ff7ce0e
--- /dev/null
+++ b/www/scloader/pkg-descr
@@ -0,0 +1,7 @@
+Smart Cache Loader is most configurable web batch downloader in world! If you
+have a very specific needs to grab some portions of web site -- this is
+right tool for you! This program can be also used as web crawler if you
+need to crawl defined parts of www site(s).
+
+
+WWW: http://scloader.sourceforge.net/