aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordb <db@FreeBSD.org>2007-07-06 00:17:06 +0800
committerdb <db@FreeBSD.org>2007-07-06 00:17:06 +0800
commitde3032e68fbb0b8aa3d1c68f8d23bdd0cb956fe1 (patch)
treeee9b91fa7c43658dec2b0449d42b81aab702ca6f
parent318775541a0bfc0af2de28837f998b8f98fc2678 (diff)
downloadfreebsd-ports-gnome-de3032e68fbb0b8aa3d1c68f8d23bdd0cb956fe1.tar.gz
freebsd-ports-gnome-de3032e68fbb0b8aa3d1c68f8d23bdd0cb956fe1.tar.zst
freebsd-ports-gnome-de3032e68fbb0b8aa3d1c68f8d23bdd0cb956fe1.zip
Fix build under -CURRENT by making it build with gcc 4.2. [1] The
introduced patch fixes a bad macro in the source code. Notified by: Pav (via pointyhat) [1] Approved: ehaupt (mentor)
-rw-r--r--comms/libfec/Makefile1
-rw-r--r--comms/libfec/files/patch-fec.h11
2 files changed, 12 insertions, 0 deletions
diff --git a/comms/libfec/Makefile b/comms/libfec/Makefile
index 7b9e553540ab..6fae412280fe 100644
--- a/comms/libfec/Makefile
+++ b/comms/libfec/Makefile
@@ -6,6 +6,7 @@
PORTNAME= libfec
PORTVERSION= 3.0
+PORTREVISION= 1
CATEGORIES= comms astro hamradio math
MASTER_SITES= http://www.ka9q.net/code/fec/ \
${MASTER_SITE_LOCAL}
diff --git a/comms/libfec/files/patch-fec.h b/comms/libfec/files/patch-fec.h
new file mode 100644
index 000000000000..831d3ca1ff3b
--- /dev/null
+++ b/comms/libfec/files/patch-fec.h
@@ -0,0 +1,11 @@
+--- fec.h.orig 2007-07-02 13:26:12.000000000 -0400
++++ fec.h 2007-07-02 13:38:26.000000000 -0400
+@@ -262,7 +262,7 @@
+ void find_cpu_mode(void); /* Call this once at startup to set Cpu_mode */
+
+ /* Determine parity of argument: 1 = odd, 0 = even */
+-#ifdef __i386__
++#ifdef notyet__i386__
+ static inline int parityb(unsigned char x){
+ __asm__ __volatile__ ("test %1,%1;setpo %0" : "=g"(x) : "r" (x));
+ return x;