aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-21 22:00:00 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-21 22:00:00 +0800
commite8989e797ab7291a8e7a40e667db08a7bf7405e9 (patch)
tree4f0095d703f621e7896c2474deb4d906a0c3e8fb
parentb8004b23e6e5099016da718b0e28316e23df63c2 (diff)
downloadfreebsd-ports-gnome-e8989e797ab7291a8e7a40e667db08a7bf7405e9.tar.gz
freebsd-ports-gnome-e8989e797ab7291a8e7a40e667db08a7bf7405e9.tar.zst
freebsd-ports-gnome-e8989e797ab7291a8e7a40e667db08a7bf7405e9.zip
Support staging
-rw-r--r--misc/ttyrec/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/misc/ttyrec/Makefile b/misc/ttyrec/Makefile
index ab909ab7d86d..710cd94f064d 100644
--- a/misc/ttyrec/Makefile
+++ b/misc/ttyrec/Makefile
@@ -10,17 +10,15 @@ MASTER_SITES= http://0xcc.net/ttyrec/
MAINTAINER= lippe@FreeBSD.org
COMMENT= Tty recorder
-PLIST_FILES= bin/ttyplay \
- bin/ttyrec \
- bin/ttytime
-
-MAN1= ttyplay.1 ttyrec.1
-BINS= ttyplay ttyrec ttytime
+MANPAGE= ttyplay.1 ttyrec.1
+BINS= ttyplay ttyrec ttytime
OPTIONS_DEFINE= OPENPTY
OPENPTY_DESC= Use openpty instead
-NO_STAGE= yes
+PLIST_FILES= bin/ttyplay bin/ttyrec bin/ttytime \
+ man/man1/ttyplay.1.gz man/man1/ttyrec.1.gz
+
.include <bsd.port.options.mk>
post-patch:
@@ -28,8 +26,9 @@ post-patch:
${WRKSRC}/Makefile
do-install:
- ${INSTALL_PROGRAM} ${BINS:S,^,${WRKSRC}/,} ${PREFIX}/bin
- ${INSTALL_MAN} ${MAN1:S,^,${WRKSRC}/,} ${MAN1PREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${BINS:S,^,${WRKSRC}/,} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${MANPAGE:S,^,${WRKSRC}/,} \
+ ${STAGEDIR}${MANPREFIX}/man/man1
.if ${PORT_OPTIONS:MOPENPTY}
CFLAGS+= -DHAVE_openpty -lutil