aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-07-23 06:22:28 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-07-23 06:22:28 +0800
commitec0bf03464f755af01300053a602b9c9772e65e2 (patch)
tree2ecc3b899a40d84e1bd31e9b17b0b684a39c7077
parent3cc97c2b92ea4d0d7cc9a0e24c2a76b310fd1339 (diff)
downloadfreebsd-ports-gnome-ec0bf03464f755af01300053a602b9c9772e65e2.tar.gz
freebsd-ports-gnome-ec0bf03464f755af01300053a602b9c9772e65e2.tar.zst
freebsd-ports-gnome-ec0bf03464f755af01300053a602b9c9772e65e2.zip
- Switch to USES=libtool, drop .la files
- Fix whitespace Approved by: portmgr blanket
-rw-r--r--databases/sfcgal/Makefile9
-rw-r--r--databases/sfcgal/pkg-plist1
2 files changed, 5 insertions, 5 deletions
diff --git a/databases/sfcgal/Makefile b/databases/sfcgal/Makefile
index 3f36393820dd..f38abe983cd5 100644
--- a/databases/sfcgal/Makefile
+++ b/databases/sfcgal/Makefile
@@ -3,6 +3,7 @@
PORTNAME= sfcgal
PORTVERSION= 1.0.4
+PORTREVISION= 1
CATEGORIES= databases math graphics
MASTER_SITES= http://github.com/Oslandia/${PORTNAME}/archive/v${PORTVERSION}.tar.gz?dummy=/
@@ -13,12 +14,12 @@ LICENSE= GPLv2
LIB_DEPENDS= libCGAL.so:${PORTSDIR}/math/cgal \
libboost_system.so:${PORTSDIR}/devel/boost-libs \
- libgmp.so:${PORTSDIR}/math/gmp \
- libmpfr.so:${PORTSDIR}/math/mpfr
+ libgmp.so:${PORTSDIR}/math/gmp \
+ libmpfr.so:${PORTSDIR}/math/mpfr
-WRKSRC= ${WRKDIR}/SFCGAL-${PORTVERSION}
+WRKSRC= ${WRKDIR}/SFCGAL-${PORTVERSION}
-USES= cmake compiler
+USES= cmake compiler libtool
compiler_ARGS= c++0x
USE_LDCONFIG= yes
diff --git a/databases/sfcgal/pkg-plist b/databases/sfcgal/pkg-plist
index b30046abd53c..48b810abbf28 100644
--- a/databases/sfcgal/pkg-plist
+++ b/databases/sfcgal/pkg-plist
@@ -104,7 +104,6 @@ include/SFCGAL/triangulate/triangulate2DZ.h
include/SFCGAL/triangulate/triangulatePolygon.h
include/SFCGAL/version.h
include/SFCGAL/version.h.cmake
-lib/libSFCGAL.la
lib/libSFCGAL.so
@dirrmtry include/SFCGAL/triangulate
@dirrmtry include/SFCGAL/io