aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2014-08-26 23:07:44 +0800
committerswills <swills@FreeBSD.org>2014-08-26 23:07:44 +0800
commitf88f38ecc9d0406aa73891ad3869de09d2860418 (patch)
treefa137290acdca4f6a9734bb14d4ba59203b68946
parent6c49d42e72a399d07dd9ea5478deceeb723ab701 (diff)
downloadfreebsd-ports-gnome-f88f38ecc9d0406aa73891ad3869de09d2860418.tar.gz
freebsd-ports-gnome-f88f38ecc9d0406aa73891ad3869de09d2860418.tar.zst
freebsd-ports-gnome-f88f38ecc9d0406aa73891ad3869de09d2860418.zip
security/rubygem-bcrypt: add rubygem-bcrypt port
bcrypt() is a sophisticated and secure hash algorithm designed by The OpenBSD project for hashing passwords. The bcrypt Ruby gem provides a simple wrapper for safely handling passwords. WWW: https://github.com/codahale/bcrypt-ruby
-rw-r--r--security/Makefile1
-rw-r--r--security/rubygem-bcrypt/Makefile16
-rw-r--r--security/rubygem-bcrypt/distinfo2
-rw-r--r--security/rubygem-bcrypt/pkg-descr5
4 files changed, 24 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index e86f9893e3bd..214689e18415 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -866,6 +866,7 @@
SUBDIR += ruby-hmac
SUBDIR += ruby-password
SUBDIR += ruby-tcpwrap
+ SUBDIR += rubygem-bcrypt
SUBDIR += rubygem-bcrypt-ruby
SUBDIR += rubygem-ezcrypto
SUBDIR += rubygem-gpgr
diff --git a/security/rubygem-bcrypt/Makefile b/security/rubygem-bcrypt/Makefile
new file mode 100644
index 000000000000..857a865802b8
--- /dev/null
+++ b/security/rubygem-bcrypt/Makefile
@@ -0,0 +1,16 @@
+# Created by: Steve Wills <swills@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= bcrypt
+PORTVERSION= 3.1.7
+CATEGORIES= security rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= OpenBSD bcrypt password hashing algorithm
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST=yes
+
+.include <bsd.port.mk>
diff --git a/security/rubygem-bcrypt/distinfo b/security/rubygem-bcrypt/distinfo
new file mode 100644
index 000000000000..5fe83b01e965
--- /dev/null
+++ b/security/rubygem-bcrypt/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/bcrypt-3.1.7.gem) = 1c30953152c7151eac21aa59eed7ea933a7bc5d5838edea1d30d79b005955702
+SIZE (rubygem/bcrypt-3.1.7.gem) = 43520
diff --git a/security/rubygem-bcrypt/pkg-descr b/security/rubygem-bcrypt/pkg-descr
new file mode 100644
index 000000000000..6bb8f0a40a10
--- /dev/null
+++ b/security/rubygem-bcrypt/pkg-descr
@@ -0,0 +1,5 @@
+bcrypt() is a sophisticated and secure hash algorithm designed by The OpenBSD
+project for hashing passwords. The bcrypt Ruby gem provides a simple wrapper
+for safely handling passwords.
+
+WWW: https://github.com/codahale/bcrypt-ruby