aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2002-11-05 02:54:18 +0800
committermarcus <marcus@FreeBSD.org>2002-11-05 02:54:18 +0800
commitfc9ee37d6280aa3943b9386d5ebdd0d787d5935c (patch)
treef3c35bd1e31b2eab8ef0a2c2f12bbb96f8546ec5
parentb6544fe528e6bf11b97826ff202ac5a4d990c706 (diff)
downloadfreebsd-ports-gnome-fc9ee37d6280aa3943b9386d5ebdd0d787d5935c.tar.gz
freebsd-ports-gnome-fc9ee37d6280aa3943b9386d5ebdd0d787d5935c.tar.zst
freebsd-ports-gnome-fc9ee37d6280aa3943b9386d5ebdd0d787d5935c.zip
Disable pthread support in pkgconfig. pkgconfig doesn't use any
threading anyway, so this does not add or remove functionality. However, this does allow pkgconfig to build on Sparc64 which is a pre-req for making the release documentation. Submitted by: tmm
-rw-r--r--devel/pkg-config/Makefile1
-rw-r--r--devel/pkgconfig/Makefile1
2 files changed, 2 insertions, 0 deletions
diff --git a/devel/pkg-config/Makefile b/devel/pkg-config/Makefile
index 5e7aa5bd9b1f..9bfc5728f04d 100644
--- a/devel/pkg-config/Makefile
+++ b/devel/pkg-config/Makefile
@@ -20,6 +20,7 @@ USE_LIBTOOL= yes
LIBTOOLFILES= glib-1.2.8/configure
LIBTOOLFLAGS= --disable-ltlibs \
--disable-shared
+CONFIGURE_ARGS= --disable-threads
MAKE_ENV= PKGCONF_BUILD=yes
PLIST_SUB= LOCALBASE=${LOCALBASE} X11BASE=${X11BASE}
diff --git a/devel/pkgconfig/Makefile b/devel/pkgconfig/Makefile
index 5e7aa5bd9b1f..9bfc5728f04d 100644
--- a/devel/pkgconfig/Makefile
+++ b/devel/pkgconfig/Makefile
@@ -20,6 +20,7 @@ USE_LIBTOOL= yes
LIBTOOLFILES= glib-1.2.8/configure
LIBTOOLFLAGS= --disable-ltlibs \
--disable-shared
+CONFIGURE_ARGS= --disable-threads
MAKE_ENV= PKGCONF_BUILD=yes
PLIST_SUB= LOCALBASE=${LOCALBASE} X11BASE=${X11BASE}