aboutsummaryrefslogtreecommitdiffstats
path: root/CHANGES
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2017-12-31 17:43:05 +0800
committertcberner <tcberner@FreeBSD.org>2017-12-31 17:43:05 +0800
commit7d25ef3ca1ec0def652a04b4f1df3ea808aff68d (patch)
treed27a6a4c588a3b8b48bdd20aeba94186a58e56bc /CHANGES
parentc8ae83175585f53743c92976db19e646502473a0 (diff)
downloadfreebsd-ports-gnome-7d25ef3ca1ec0def652a04b4f1df3ea808aff68d.tar.gz
freebsd-ports-gnome-7d25ef3ca1ec0def652a04b4f1df3ea808aff68d.tar.zst
freebsd-ports-gnome-7d25ef3ca1ec0def652a04b4f1df3ea808aff68d.zip
Add CMAKE_ON and CMAKE_OFF to cmake.mk
USES=cmake now supports two additional list variables: * CMAKE_ON : List of variables to turn on * CMAKE_OFF : List of variables to turn off This can be used as a shortcut to append these to CMAKE_ARGS. For example ports that previously set CMAKE_ARGS= -DVAR1:BOOL=TRUE -DVAR2:BOOL=TRUE -DVAR3:BOOL=FALSE can now set this as CMAKE_ON= VAR1 VAR2 CMAKE_OFF= VAR3 Reviewed by: adridg, rakuco, mat Differential Revision: https://reviews.freebsd.org/D13636
Diffstat (limited to 'CHANGES')
-rw-r--r--CHANGES14
1 files changed, 14 insertions, 0 deletions
diff --git a/CHANGES b/CHANGES
index 920bfd75ddb4..d1c633cc27a2 100644
--- a/CHANGES
+++ b/CHANGES
@@ -10,6 +10,20 @@ in the release notes and/or placed into UPDATING.
All ports committers are allowed to commit to this file.
+20171231:
+AUTHOR: kde@FreeBSD.org
+
+ USES=cmake now supports two additional list variables:
+ * CMAKE_ON : List of variables to turn on
+ * CMAKE_OFF : List of variables to turn off
+ This can be used as a shortcut to append these to CMAKE_ARGS.
+
+ For example ports that previously set
+ CMAKE_ARGS= -DVAR1:BOOL=TRUE -DVAR2:BOOL=TRUE -DVAR3:BOOL=FALSE
+ can now set this as
+ CMAKE_ON= VAR1 VAR2
+ CMAKE_OFF= VAR3
+
20171130:
AUTHOR: mat@FreeBSD.org