diff options
author | bdrewery <bdrewery@FreeBSD.org> | 2014-04-12 11:39:02 +0800 |
---|---|---|
committer | bdrewery <bdrewery@FreeBSD.org> | 2014-04-12 11:39:02 +0800 |
commit | 39e2243ab529e4b7a16e7f4906892b155afd5a73 (patch) | |
tree | b5235113da17195fc36663198e7440dd31ce2cc8 /CHANGES | |
parent | 7687f0c989b1baac6fb46a477dae6aace752f3b8 (diff) | |
download | freebsd-ports-gnome-39e2243ab529e4b7a16e7f4906892b155afd5a73.tar.gz freebsd-ports-gnome-39e2243ab529e4b7a16e7f4906892b155afd5a73.tar.zst freebsd-ports-gnome-39e2243ab529e4b7a16e7f4906892b155afd5a73.zip |
- Add a @sample plist keyword
It accepts a file (must end in .sample, this is not configurable):
@sample file.conf.sample
This will install file.conf.sample and copy it to file.conf. The file.conf
will be removed if it matches file.conf.sample on deinstall.
This replaces older patterns of:
@unexec if cmp -s %D/etc/pkgtools.conf %D/etc/pkgtools.conf.sample; then rm -f %D/etc/pkgtools.conf; fi
etc/pkgtools.conf.sample
@exec [ -f %B/pkgtools.conf ] || cp %B/%f %B/pkgtools.conf
[1] This somewhat obsoletes work in ports/157168 which added CONF_FILES,
but we have been moving towards more logic in pkg-plist where possible
and less magical macros. Though this thinking does clash with autoplist
ideas. We may still want CONF_FILES, which just drops a list of
@sample entries into the plist anyway.
- Add a Keywords/pkg_install.awk and hook it into generate-plist. This is
for pkg_install compatibility since it does not know how to read
Keywords/sample.yaml.
This file gives us a strategy to implement more keywords before
pkg_install is EOL.
Keywords are documented here:
https://github.com/freebsd/pkg/commit/bffc31420b1fd6146a43c9abcd45109dd901198a
- This needs to be documented in PH and portlint support added still.
PR: ports/157168 [1]
Discussed with: bapt
Reviewed by: bapt
Requested by: many
With hat: portmgr
Diffstat (limited to 'CHANGES')
-rw-r--r-- | CHANGES | 17 |
1 files changed, 17 insertions, 0 deletions
@@ -10,6 +10,23 @@ in the release notes and/or placed into UPDATING. All ports committers are allowed to commit to this file. +20140411: +AUTHOR: bdrewery@FreeBSD.org + + A new plist keyword has been added, @sample. It accepts a file (must end in + .sample): + + @sample file.conf.sample + + This will install file.conf.sample and copy it to file.conf. The file.conf + will be removed if it matches file.conf.sample on deinstall. + + This replaces older patterns of: + + @unexec if cmp -s %D/etc/pkgtools.conf %D/etc/pkgtools.conf.sample; then rm -f %D/etc/pkgtools.conf; fi + etc/pkgtools.conf.sample + @exec [ -f %B/pkgtools.conf ] || cp %B/%f %B/pkgtools.conf + 20140312: AUTHOR: bapt@FreeBSD.org |