aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-11-16 05:05:18 +0800
committerpav <pav@FreeBSD.org>2004-11-16 05:05:18 +0800
commit9cf5900d15a4424a323399bfd47ed3c21c9d8bff (patch)
tree06da1ed197bcb55de612c70dec378166061ee0ff /Makefile
parentc673285cc5508ad66b468a28038ab22d5a33c0dd (diff)
downloadfreebsd-ports-gnome-9cf5900d15a4424a323399bfd47ed3c21c9d8bff.tar.gz
freebsd-ports-gnome-9cf5900d15a4424a323399bfd47ed3c21c9d8bff.tar.zst
freebsd-ports-gnome-9cf5900d15a4424a323399bfd47ed3c21c9d8bff.zip
- In fetchindex target:
Fetch bzip2 compressed copy of INDEX and decompress locally. This should cut down both time and bandwidth. Approved by: kris (portmgr hat)
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index b9ac02bcc7ea..534b99a04731 100644
--- a/Makefile
+++ b/Makefile
@@ -71,7 +71,7 @@ index:
@cd ${.CURDIR} && make ${.CURDIR}/${INDEXFILE}
fetchindex:
- @cd ${.CURDIR} && fetch -am http://www.FreeBSD.org/ports/${INDEXFILE} && chmod a+r ${INDEXFILE}
+ @cd ${.CURDIR} && fetch -am http://www.FreeBSD.org/ports/${INDEXFILE}.bz2 && bunzip2 -f ${INDEXFILE}.bz2 && chmod a+r ${INDEXFILE}
INDEX_JOBS?= 2