diff options
author | joe <joe@FreeBSD.org> | 2000-03-23 04:36:55 +0800 |
---|---|---|
committer | joe <joe@FreeBSD.org> | 2000-03-23 04:36:55 +0800 |
commit | 17e258716735a734ac78453f933869cf17475890 (patch) | |
tree | 8c009969cb6751d92bad3c9ab5d7c6a5a025f131 /Makefile | |
parent | 41468e9c93b33035d055c0a7b9d4bcba799b7b8c (diff) | |
download | freebsd-ports-gnome-17e258716735a734ac78453f933869cf17475890.tar.gz freebsd-ports-gnome-17e258716735a734ac78453f933869cf17475890.tar.zst freebsd-ports-gnome-17e258716735a734ac78453f933869cf17475890.zip |
Additions to the 'make search' mechanism.
* You can now 'make search' from a ports subdirectory. This will
will restrict the search to ports within this subdirectory.
* Added an additional search option to search just the port names,
e.g. 'make search name=foo' will only return ports that have 'foo' in their
name.
Approved by: asami
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 8 |
1 files changed, 0 insertions, 8 deletions
@@ -70,14 +70,6 @@ ${.CURDIR}/INDEX: print-index: ${.CURDIR}/INDEX @awk -F\| '{ printf("Port:\t%s\nPath:\t%s\nInfo:\t%s\nMaint:\t%s\nIndex:\t%s\nB-deps:\t%s\nR-deps:\t%s\n\n", $$1, $$2, $$4, $$6, $$7, $$8, $$9); }' < ${.CURDIR}/INDEX -search: ${.CURDIR}/INDEX -.if !defined(key) - @echo "The search target requires a keyword parameter," - @echo "e.g.: \"make search key=somekeyword\"" -.else - @grep -i "${key}" ${.CURDIR}/INDEX | awk -F\| '{ printf("Port:\t%s\nPath:\t%s\nInfo:\t%s\nMaint:\t%s\nIndex:\t%s\nB-deps:\t%s\nR-deps:\t%s\n\n", $$1, $$2, $$4, $$6, $$7, $$8, $$9); }' -.endif - parallel: ${.CURDIR}/INDEX .for dir in ${SUBDIR} @echo "all:: ${dir}-all" |