diff options
author | billf <billf@FreeBSD.org> | 1999-06-01 10:55:43 +0800 |
---|---|---|
committer | billf <billf@FreeBSD.org> | 1999-06-01 10:55:43 +0800 |
commit | 1e49f75cb893e5e7e53089189a3b88b3d0a81aa7 (patch) | |
tree | a977ad8f325bd6b4b02599ae96a3f9b76b724612 /Makefile | |
parent | 00753de756e75bd5a9be170fc615a24b3e736d69 (diff) | |
download | freebsd-ports-gnome-1e49f75cb893e5e7e53089189a3b88b3d0a81aa7.tar.gz freebsd-ports-gnome-1e49f75cb893e5e7e53089189a3b88b3d0a81aa7.tar.zst freebsd-ports-gnome-1e49f75cb893e5e7e53089189a3b88b3d0a81aa7.zip |
'make update' in the ports directory.
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 18 |
1 files changed, 17 insertions, 1 deletions
@@ -1,4 +1,4 @@ -# $Id: Makefile,v 1.45 1999/01/22 10:32:32 asami Exp $ +# $Id: Makefile,v 1.46 1999/01/26 03:58:55 asami Exp $ # SUBDIR += archivers @@ -73,3 +73,19 @@ parallel: ${.CURDIR}/INDEX @echo "all:: ${dir}-all" .endfor @sed -e 's/|/.tgz|/' ${.CURDIR}/INDEX | awk -F '|' '{me=$$1; here=$$2; bdep=$$8; rdep=$$9; split(here, tmp, "/"); if (bdep != "") { gsub("$$", ".tgz", bdep); gsub(" ", ".tgz ", bdep); } if (rdep != "") { gsub("$$", ".tgz", rdep); gsub(" ", ".tgz ", rdep); } print tmp[4] "-all:: " me; print me ": " bdep " " rdep; printf("\t@/a/asami/portbuild/scripts/pdispatch /a/asami/portbuild/scripts/portbuild %s %s", me, here); if (bdep != "") printf(" %s", bdep); if (rdep != "") printf(" %s", rdep); printf("\n")}' + +update: +.if defined(SUP_UPDATE) + @echo "--------------------------------------------------------------" + @echo ">>> Running ${SUP}" + @echo "--------------------------------------------------------------" +.if defined(PORTSSUPFILE) + @${SUP} ${SUPFLAGS} ${PORTSSUPFILE} +.endif +.endif +.if defined(CVS_UPDATE) + @echo "--------------------------------------------------------------" + @echo ">>> Updating /usr/src from cvs repository" ${CVSROOT} + @echo "--------------------------------------------------------------" + cd ${.CURDIR}; cvs -q update -P -d +.endif |