aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2016-04-13 10:02:43 +0800
committerswills <swills@FreeBSD.org>2016-04-13 10:02:43 +0800
commit40dd48477b84fc0ce43dd7acee208a99ca5fcd19 (patch)
tree61105b4ed0c6543b1063ac2e0c737a9dda14a676 /Makefile
parent74154cd4bd758c21559e68fc739306c8b8cf4583 (diff)
downloadfreebsd-ports-gnome-40dd48477b84fc0ce43dd7acee208a99ca5fcd19.tar.gz
freebsd-ports-gnome-40dd48477b84fc0ce43dd7acee208a99ca5fcd19.tar.zst
freebsd-ports-gnome-40dd48477b84fc0ce43dd7acee208a99ca5fcd19.zip
Try harder to find svn
Don't assume svn is installed, but use it if it's available, falling back to svnlite if not (or using svn from base in the case where WITH_SVN was set in base). This matches the logic in base for finding svn. PR: 207479 Discussed with: gjb Reported by: Torsten Zühlsdorff <ports@toco-domains.de>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 5ea40e5cb77f..d89e2daed479 100644
--- a/Makefile
+++ b/Makefile
@@ -164,7 +164,15 @@ print-index: ${INDEXDIR}/${INDEXFILE}
@awk -F\| '{ printf("Port:\t%s\nPath:\t%s\nInfo:\t%s\nMaint:\t%s\nIndex:\t%s\nB-deps:\t%s\nR-deps:\t%s\nE-deps:\t%s\nP-deps:\t%s\nF-deps:\t%s\nWWW:\t%s\n\n", $$1, $$2, $$4, $$6, $$7, $$8, $$9, $$11, $$12, $$13, $$10); }' < ${INDEXDIR}/${INDEXFILE}
GIT?= git
-SVN?= svn
+.if !defined(SVN) || empty(SVN)
+. for _P in /usr/bin /usr/local/bin
+. for _S in svn svnlite
+. if exists(${_P}/${_S})
+SVN= ${_P}/${_S}
+. endif
+. endfor
+. endfor
+.endif
RSYNC?= rsync
PORTSNAP?= portsnap
PORTSNAP_FLAGS?= -p ${.CURDIR}