aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2014-08-18 12:19:46 +0800
committerkoobs <koobs@FreeBSD.org>2014-08-18 12:19:46 +0800
commit9772573436bb202afbce6d6dbb7d8e773d2fb4bc (patch)
treec4c9a94f8386b7a0cbc9cc086a410eea4dc351e2 /Makefile
parent062ebaf0d630c989d88e9c59272bb3f273d2dbf5 (diff)
downloadfreebsd-ports-gnome-9772573436bb202afbce6d6dbb7d8e773d2fb4bc.tar.gz
freebsd-ports-gnome-9772573436bb202afbce6d6dbb7d8e773d2fb4bc.tar.zst
freebsd-ports-gnome-9772573436bb202afbce6d6dbb7d8e773d2fb4bc.zip
Makefile: Default INDEX_JOBS value to kern.smp.cpus
INDEX_JOBS currently defaults to 2 for the make index target. MAKE_JOBS_NUMBER in bsd.port.mk currently uses kern.smp.cpus to select a default. Modify INDEX_JOBS to match. Nominal and repeatable performance improvements of ~20-30% were observed. CR: D381 Reviewed by: swills, bdrewery Approved by: portmgr
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 8b8f9d6f2395..5ea40e5cb77f 100644
--- a/Makefile
+++ b/Makefile
@@ -82,7 +82,10 @@ ${INDEXDIR}/${INDEXFILE}.bz2: .PHONY
MASTER_SITE_INDEX?= http://www.FreeBSD.org/ports/
SETENV?= /usr/bin/env
FETCHINDEX?= ${SETENV} ${FETCH_ENV} fetch -am -o
-INDEX_JOBS?= 2
+
+.if !defined(INDEX_JOBS)
+INDEX_JOBS!= ${SYSCTL} -n kern.smp.cpus
+.endif
.if !defined(INDEX_VERBOSE)
INDEX_ECHO_MSG= true