aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-05-02 20:05:48 +0800
committerbapt <bapt@FreeBSD.org>2013-05-02 20:05:48 +0800
commit4ac0c59daaa5433c8155d6f39c386ebecd2f4bfb (patch)
treefee472e74fc8814e175cf170dbae641092e55b5f /Makefile
parentbd4f30647c6517d77396eef64570b3ead68cf215 (diff)
downloadfreebsd-ports-gnome-4ac0c59daaa5433c8155d6f39c386ebecd2f4bfb.tar.gz
freebsd-ports-gnome-4ac0c59daaa5433c8155d6f39c386ebecd2f4bfb.tar.zst
freebsd-ports-gnome-4ac0c59daaa5433c8155d6f39c386ebecd2f4bfb.zip
Do not hardcode make for make index
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 960f67784479..2dc83dbe9264 100644
--- a/Makefile
+++ b/Makefile
@@ -70,7 +70,7 @@ PORTSTOP= yes
index:
@rm -f ${INDEXDIR}/${INDEXFILE}
- @cd ${.CURDIR} && make ${INDEXDIR}/${INDEXFILE}
+ @cd ${.CURDIR} && ${MAKE} ${INDEXDIR}/${INDEXFILE}
fetchindex: ${INDEXDIR}/${INDEXFILE}.bz2
@bunzip2 < ${INDEXDIR}/${INDEXFILE}.bz2 > ${INDEXDIR}/${INDEXFILE} && \
@@ -112,7 +112,7 @@ ${INDEXDIR}/${INDEXFILE}:
fi; \
tmpdir=`/usr/bin/mktemp -d -t index` || exit 1; \
trap "rm -rf $${tmpdir}; exit 1" 1 2 3 5 10 13 15; \
- ( cd ${.CURDIR}; for i in ${INDEX_PORTS}; do (cd $${i} && make -j${INDEX_JOBS} INDEX_TMPDIR=$${tmpdir} BUILDING_INDEX=1 \
+ ( cd ${.CURDIR}; for i in ${INDEX_PORTS}; do (cd $${i} && ${MAKE} -j${INDEX_JOBS} INDEX_TMPDIR=$${tmpdir} BUILDING_INDEX=1 \
__MAKE_SHELL=${INDEX_SHELL} \
ECHO_MSG="${INDEX_ECHO_MSG}" describe); done ) || \
(rm -rf $${tmpdir} ; \