aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-04-13 19:28:57 +0800
committermat <mat@FreeBSD.org>2016-04-13 19:28:57 +0800
commit308c698a7e71214b8a3633b58277a94c7fdfa0bc (patch)
tree147e0da3de3e927ecfed8e98e858b8b6b0462316 /Makefile
parentd05d98d0dddc362a5d78b0a9acc7534062d026bb (diff)
downloadfreebsd-ports-gnome-308c698a7e71214b8a3633b58277a94c7fdfa0bc.tar.gz
freebsd-ports-gnome-308c698a7e71214b8a3633b58277a94c7fdfa0bc.tar.zst
freebsd-ports-gnome-308c698a7e71214b8a3633b58277a94c7fdfa0bc.zip
Have make update work for a git only repository.
PR: 195699 Submitted by: clutton zoho com Sponsored by: Absolight
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index d89e2daed479..7e3bed5d4768 100644
--- a/Makefile
+++ b/Makefile
@@ -184,10 +184,17 @@ update:
@echo "--------------------------------------------------------------"
cd ${.CURDIR}; ${SVN} update
.elif exists(${.CURDIR}/.git)
+. if exists(${.CURDIR}/.git/svn)
@echo "--------------------------------------------------------------"
@echo ">>> Updating ${.CURDIR} from git+svn repository"
@echo "--------------------------------------------------------------"
cd ${.CURDIR}; ${GIT} svn rebase
+. else
+ @echo "--------------------------------------------------------------"
+ @echo ">>> Updating ${.CURDIR} from git repository"
+ @echo "--------------------------------------------------------------"
+ cd ${.CURDIR}; ${GIT} pull
+. endif
.elif defined(RSYNC_UPDATE) && defined(PORTS_RSYNC_SOURCE)
@echo "--------------------------------------------------------------"
@echo ">>> Updating with ${RSYNC} from ${PORTS_RSYNC_SOURCE}"