aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Scripts
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-06-27 19:31:10 +0800
committermat <mat@FreeBSD.org>2016-06-27 19:31:10 +0800
commit82a234f5c1d92aab301c663775859cfec043f06b (patch)
tree1b037def670694489104abae09b8b8337f0e5a08 /Mk/Scripts
parentce1eac9e2628f5b9255c5e38be1f9bf9c1183409 (diff)
downloadfreebsd-ports-gnome-82a234f5c1d92aab301c663775859cfec043f06b.tar.gz
freebsd-ports-gnome-82a234f5c1d92aab301c663775859cfec043f06b.tar.zst
freebsd-ports-gnome-82a234f5c1d92aab301c663775859cfec043f06b.zip
Replace bsd.openssl.mk with USES=ssl
Add a qa hint about needing, or not, USES=ssl. Fix ports doing silly things, like including bsd.openssl.mk directly. PR: 210322 Submitted by: mat Exp-run by: antoine Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D6866
Diffstat (limited to 'Mk/Scripts')
-rw-r--r--Mk/Scripts/qa.sh9
1 files changed, 9 insertions, 0 deletions
diff --git a/Mk/Scripts/qa.sh b/Mk/Scripts/qa.sh
index 3462295ee290..e23e1c1c01a5 100644
--- a/Mk/Scripts/qa.sh
+++ b/Mk/Scripts/qa.sh
@@ -98,6 +98,7 @@ shebang() {
baselibs() {
local rc
+ local found_openssl
[ "${PKGBASE}" = "pkg" -o "${PKGBASE}" = "pkg-devel" ] && return
while read f; do
case ${f} in
@@ -109,12 +110,20 @@ baselibs() {
err "Bad linking on ${f##* } please add USES=libedit"
rc=1
;;
+ *NEEDED*\[libcrypto.so.*]|*NEEDED*\[libssl.so.*])
+ found_openssl=1
+ ;;
esac
done <<-EOF
$(find ${STAGEDIR}${PREFIX}/bin ${STAGEDIR}${PREFIX}/sbin \
${STAGEDIR}${PREFIX}/lib ${STAGEDIR}${PREFIX}/libexec \
-type f -exec readelf -d {} + 2>/dev/null)
EOF
+ if [ -z "${USESSSL}" -a -n "${found_openssl}" ]; then
+ warn "you need USES=nssl"
+ elif [ -n "${USESSSL}" -a -z "${found_openssl}" ]; then
+ warn "you may not need USES=ssl"
+ fi
return ${rc}
}