aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Scripts
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-04-22 04:17:00 +0800
committerantoine <antoine@FreeBSD.org>2014-04-22 04:17:00 +0800
commit8eab31bb7fce81a635f9c807b32ebd2f2334a286 (patch)
treeb9a1437f890e9dbbc3e3810ef6226e48c70d74d3 /Mk/Scripts
parent706c75a7ac95183fcef83eea2bf225f0db24c095 (diff)
downloadfreebsd-ports-gnome-8eab31bb7fce81a635f9c807b32ebd2f2334a286.tar.gz
freebsd-ports-gnome-8eab31bb7fce81a635f9c807b32ebd2f2334a286.tar.zst
freebsd-ports-gnome-8eab31bb7fce81a635f9c807b32ebd2f2334a286.zip
- Do not advise to strip non FreeBSD binaries [1]
- Shorten messages Requested and tested by: xmj [1] With hat: portmgr
Diffstat (limited to 'Mk/Scripts')
-rw-r--r--Mk/Scripts/qa.sh8
1 files changed, 4 insertions, 4 deletions
diff --git a/Mk/Scripts/qa.sh b/Mk/Scripts/qa.sh
index 3a708426f346..c54010a15500 100644
--- a/Mk/Scripts/qa.sh
+++ b/Mk/Scripts/qa.sh
@@ -81,7 +81,7 @@ symlinks() {
[ -z "${l}" ] && continue
case "${link}" in
${STAGEDIR}*)
- err "Bad symlinks ${l} pointing inside the stage directory"
+ err "Bad symlinks ${l#${STAGEDIR}${PREFIX}/} pointing inside the stage directory"
rc=1
;;
esac
@@ -106,7 +106,7 @@ paths() {
*/lib/ruby/gems/*/Makefile.html) continue ;;
*/lib/ruby/gems/*/mkmf.log) continue ;;
esac
- err "${f} is referring to ${STAGEDIR}"
+ err "${f#${STAGEDIR}${PREFIX}/} is referring to ${STAGEDIR}"
rc=1
# Use heredoc to avoid losing rc from find|while subshell
done << EOF
@@ -123,8 +123,8 @@ stripped() {
find ${STAGEDIR} -type f -exec /usr/bin/file -nNF '' {} + | while
read f output; do
case "${output}" in
- ELF\ *\ executable,\ *,\ not\ stripped*|ELF\ *\ shared\ object,\ *,\ not\ stripped*)
- warn "${f} is not stripped consider using \${STRIP_CMD}"
+ ELF\ *\ executable,\ *FreeBSD*,\ not\ stripped*|ELF\ *\ shared\ object,\ *FreeBSD*,\ not\ stripped*)
+ warn "${f#${STAGEDIR}${PREFIX}/} is not stripped consider using \${STRIP_CMD}"
;;
esac
done