aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Scripts
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2014-08-19 22:36:49 +0800
committerbdrewery <bdrewery@FreeBSD.org>2014-08-19 22:36:49 +0800
commit4561d1bda0eb7f1e537837bc22be42424c72313b (patch)
treea9469e66f75e17aa17fc93df425914e1a3aeea48 /Mk/Scripts
parente9c38e0e619d944e626afce396d7879e50c113cd (diff)
downloadfreebsd-ports-gnome-4561d1bda0eb7f1e537837bc22be42424c72313b.tar.gz
freebsd-ports-gnome-4561d1bda0eb7f1e537837bc22be42424c72313b.tar.zst
freebsd-ports-gnome-4561d1bda0eb7f1e537837bc22be42424c72313b.zip
- Add the same workaround for ignoring PREFIX/info removal when PREFIX !=
LOCALBASE, as check-stagedir has. With hat: portmgr
Diffstat (limited to 'Mk/Scripts')
-rw-r--r--Mk/Scripts/check_leftovers.sh8
1 files changed, 8 insertions, 0 deletions
diff --git a/Mk/Scripts/check_leftovers.sh b/Mk/Scripts/check_leftovers.sh
index 7dc4982f91a1..d060bf281198 100644
--- a/Mk/Scripts/check_leftovers.sh
+++ b/Mk/Scripts/check_leftovers.sh
@@ -108,11 +108,19 @@ while read modtype path extra; do
esac
;;
-)
+ # Skip removal of PREFIX and PREFIX/info from
+ # bsd.port.mk for now.
# Skip if it is PREFIX and non-LOCALBASE. See misc/kdehier4
# or mail/qmail for examples
[ "${path}" = "${PREFIX}" -a "${LOCALBASE}" != "${PREFIX}" ] &&
ignore_path=1
+ # The removal of info may be a bug; it's part of BSD.local.dist.
+ # See ports/74691
+
+ [ "${sub_path}" = "info" -a "${LOCALBASE}" != "${PREFIX}" ] &&
+ ignore_path=1
+
[ $ignore_path -eq 0 ] && echo "- ${sub_path}"
;;
M)