aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Uses/gmake.mk
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-09-29 00:36:31 +0800
committertijl <tijl@FreeBSD.org>2014-09-29 00:36:31 +0800
commite7dc30958a42e788cc3320e65536192f3476ef87 (patch)
treeaeb03f1aa94222d62e9cdc28c4130adb5b0e5327 /Mk/Uses/gmake.mk
parentccd08de0500ddc8e427dc1bbf85fc534336cc7f8 (diff)
downloadfreebsd-ports-gnome-e7dc30958a42e788cc3320e65536192f3476ef87.tar.gz
freebsd-ports-gnome-e7dc30958a42e788cc3320e65536192f3476ef87.tar.zst
freebsd-ports-gnome-e7dc30958a42e788cc3320e65536192f3476ef87.zip
Change the way USES is handled:
- Loop over USES twice, once to define all *_ARGS variables and once to include Uses/*.mk. This allows all Uses/*.mk to examine arguments given to other USES entries. - Always define *_ARGS (possibly empty) and replace commas with spaces. Similar for _USES_POST. Adjust all Uses/*.mk: - defined(u_ARGS) becomes !empty(u_ARGS) - Eliminate helper variables like _*_ARGS=${*_ARGS:C/,/ /g} - Some Uses/*.mk used ":" as argument separator instead of ",", but no port used this form - Uses/cran.mk: remove unused variable VALID_ARGS and USES+=fortran which has no effect - Uses/twisted.mk: simplify handling of the case where neither "build" nor "run" arguments have been specified PR: 193931 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'Mk/Uses/gmake.mk')
-rw-r--r--Mk/Uses/gmake.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/Uses/gmake.mk b/Mk/Uses/gmake.mk
index 4ff7a0a84993..f650ec2aec4c 100644
--- a/Mk/Uses/gmake.mk
+++ b/Mk/Uses/gmake.mk
@@ -10,7 +10,7 @@
.if !defined(_INCLUDE_USES_GMAKE_MK)
_INCLUDE_USES_GMAKE_MK= yes
-.if defined(gmake_ARGS)
+.if !empty(gmake_ARGS)
.if ${gmake_ARGS} == lite
_GMAKE_EXT= -lite
.else