aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Uses
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-05-25 19:37:28 +0800
committermat <mat@FreeBSD.org>2014-05-25 19:37:28 +0800
commit01a4b0c9f472c02e80eed54c36271d60a9f0446f (patch)
tree97d5a20eef889fec15cdbda6fbc2a7689aa2089d /Mk/Uses
parentf8b95843d3139d39a984f66924e29c548bbf294a (diff)
downloadfreebsd-ports-gnome-01a4b0c9f472c02e80eed54c36271d60a9f0446f.tar.gz
freebsd-ports-gnome-01a4b0c9f472c02e80eed54c36271d60a9f0446f.tar.zst
freebsd-ports-gnome-01a4b0c9f472c02e80eed54c36271d60a9f0446f.zip
- Add a USE_PERL5=fixpacklist to account for ports creating one when not using
USE_PERL5=configure or USE_PERL5=modbuildtiny. - Change perl5.mk to use a specific target and not abuse post-stage. Reviewed by: bapt With Hat: portmgr Sponsored by: Absolight
Diffstat (limited to 'Mk/Uses')
-rw-r--r--Mk/Uses/perl5.mk8
1 files changed, 5 insertions, 3 deletions
diff --git a/Mk/Uses/perl5.mk b/Mk/Uses/perl5.mk
index fdd8d21fca02..400be53a0aad 100644
--- a/Mk/Uses/perl5.mk
+++ b/Mk/Uses/perl5.mk
@@ -24,7 +24,9 @@
# SITE_PERL - Directory name where site specific perl packages go.
# This value is added to PLIST_SUB.
# USE_PERL5 - If set, this port uses perl5 in one or more of the extract,
-# patch, build, install or run phases.
+# patch, build, install or run phases. The fixpacklist is
+# needed in some cases, when a .packlist is created, it may
+# reference ${STAGEDIR}
# It can also have configure, modbuild and modbuildtiny when
# the port needs to run Makefile.PL, Build.PL and a
# Module::Build::Tiny flavor of Build.PL.
@@ -254,8 +256,8 @@ do-install:
.endif # modbuild
# TODO: change to ${_USE_PERL5:Mconfigure} when M::B creates .packlist
-.if ${USE_PERL5:Mconfigure} || ${USE_PERL5:Mmodbuildtiny}
-post-stage::
+.if ${USE_PERL5:Mconfigure} || ${USE_PERL5:Mmodbuildtiny} || ${USE_PERL5:Mfixpacklist}
+fix-packlist::
-@[ -d ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto ] && ${FIND} ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto -name .packlist -exec ${SED} -i '' 's|^${STAGEDIR}||' '{}' \;
.endif