aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Uses
diff options
context:
space:
mode:
authordbn <dbn@FreeBSD.org>2016-07-24 16:45:30 +0800
committerdbn <dbn@FreeBSD.org>2016-07-24 16:45:30 +0800
commit01f273666434d2101eb192800ea00c94a8724a43 (patch)
treedb09b61cf8a9a69a008edcc5f471554d142f2cfa /Mk/Uses
parentd33a95f7c6f85ba08cc3e5753ca51db8a8e610ec (diff)
downloadfreebsd-ports-gnome-01f273666434d2101eb192800ea00c94a8724a43.tar.gz
freebsd-ports-gnome-01f273666434d2101eb192800ea00c94a8724a43.tar.zst
freebsd-ports-gnome-01f273666434d2101eb192800ea00c94a8724a43.zip
Mk/Uses/tcl.mk: fix stage-qa linking error.
- If a port links to libtk then it will always also link to libtcl. Include libtcl in the LIB_DEPENDS when linking to libtk. - Fix indentation of '.if' statements PR: 211261 Approved by: gahr MFH: 2016Q3
Diffstat (limited to 'Mk/Uses')
-rw-r--r--Mk/Uses/tcl.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/Mk/Uses/tcl.mk b/Mk/Uses/tcl.mk
index 11fb368c9ef6..4db96cc5e6bf 100644
--- a/Mk/Uses/tcl.mk
+++ b/Mk/Uses/tcl.mk
@@ -184,12 +184,13 @@ _TCLTK_WRAPPER_PORT= wish:x11-toolkits/tk-wrapper
.endif
# Construct the correct dependency lines (Tcl/Tk)
-. if ${_TCLTK_PORT} == "tcl"
+.if ${_TCLTK_PORT} == "tcl"
_TCLTK_EXE_LINE= tclsh${TCL_VER}:lang/tcl${_TCLTK_WANTED_VERSION}
_TCLTK_LIB_LINE= libtcl${TCL_SHLIB_VER}.so:lang/tcl${_TCLTK_WANTED_VERSION}
-. elif ${_TCLTK_PORT} == "tk"
+.elif ${_TCLTK_PORT} == "tk"
_TCLTK_EXE_LINE= wish${TK_VER}:x11-toolkits/tk${_TCLTK_WANTED_VERSION}
-_TCLTK_LIB_LINE= libtk${TK_SHLIB_VER}.so:x11-toolkits/tk${_TCLTK_WANTED_VERSION}
+_TCLTK_LIB_LINE= libtk${TK_SHLIB_VER}.so:x11-toolkits/tk${_TCLTK_WANTED_VERSION} \
+ libtcl${TCL_SHLIB_VER}.so:lang/tcl${_TCLTK_WANTED_VERSION}
.endif
.if ${tcl_ARGS:Mbuild}