aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Uses
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2016-10-04 14:18:32 +0800
committertcberner <tcberner@FreeBSD.org>2016-10-04 14:18:32 +0800
commit17ac414c588abf6e2975194073a7a4ca4064d1f4 (patch)
tree08221937e7bdf0f6fca91d674e2658c6d87749d4 /Mk/Uses
parent358d440caa7e83adb2f7422d47d6adb606a38a89 (diff)
downloadfreebsd-ports-gnome-17ac414c588abf6e2975194073a7a4ca4064d1f4.tar.gz
freebsd-ports-gnome-17ac414c588abf6e2975194073a7a4ca4064d1f4.tar.zst
freebsd-ports-gnome-17ac414c588abf6e2975194073a7a4ca4064d1f4.zip
Teach pathfix.mk about LIB_DESTINATION
Some cmake projects use LIB_DESTINATION/pkgconfig to install the pc-files. For example: * deskutils/libstreamanalyzer * sysutils/polkit-qt{,5} * x11-toolkits/attica By adding this, we can convert these ports to use pathfix instead of an uncessessary patch-foo or confusing sed call. Reviewed by: mat Approved by: portmgr (mat), mat (mentor) Differential Revision: https://reviews.freebsd.org/D8141
Diffstat (limited to 'Mk/Uses')
-rw-r--r--Mk/Uses/pathfix.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/Mk/Uses/pathfix.mk b/Mk/Uses/pathfix.mk
index 73af954c7628..c120b6f785f1 100644
--- a/Mk/Uses/pathfix.mk
+++ b/Mk/Uses/pathfix.mk
@@ -27,6 +27,7 @@ pathfix:
's|[{]CMAKE_INSTALL_LIBDIR[}]/pkgconfig|{CMAKE_INSTALL_PREFIX}/libdata/pkgconfig|g ; \
s|[{]INSTALL_LIB_DIR[}]/pkgconfig|{CMAKE_INSTALL_PREFIX}/libdata/pkgconfig|g ; \
s|[{]INSTALL_LIBDIR[}]/pkgconfig|{CMAKE_INSTALL_PREFIX}/libdata/pkgconfig|g ; \
+ s|[{]LIB_DESTINATION[}]/pkgconfig|{CMAKE_INSTALL_PREFIX}/libdata/pkgconfig|g ; \
s|[{]LIB_DIR[}]/pkgconfig|{CMAKE_INSTALL_PREFIX}/libdata/pkgconfig|g ; \
s|[{]LIB_INSTALL_DIR[}]/pkgconfig|{CMAKE_INSTALL_PREFIX}/libdata/pkgconfig|g ; \
s|[{]KDE_INSTALL_LIBDIR[}]/pkgconfig|{CMAKE_INSTALL_PREFIX}/libdata/pkgconfig|g ; \