aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Uses
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2016-03-24 23:47:50 +0800
committertijl <tijl@FreeBSD.org>2016-03-24 23:47:50 +0800
commit21d48548332630b12fabb94476af7bdd7352ad13 (patch)
tree9a9bfdddc0d5bd83f4f805c6db760afc834ef9b7 /Mk/Uses
parentcf705f9c969820524bcad11ab5be15d156853a47 (diff)
downloadfreebsd-ports-gnome-21d48548332630b12fabb94476af7bdd7352ad13.tar.gz
freebsd-ports-gnome-21d48548332630b12fabb94476af7bdd7352ad13.tar.zst
freebsd-ports-gnome-21d48548332630b12fabb94476af7bdd7352ad13.zip
Make print/ghostscript9-agpl-base the default Ghostscript port. Upstream
changed the license to the AGPL 3 in version 9.07 so print/ghostscript9-base is stuck at 9.06 which is almost 4 years old now. Fix the logic in Uses/ghostscript.mk so "agpl" is treated as a real version on its own instead of as a variant of other versions. Fix print/ghostscript9-agpl-base to install eps2write. Update math/asymptote to 2.37 to support newer Ghostscript. PR: 208159 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'Mk/Uses')
-rw-r--r--Mk/Uses/ghostscript.mk21
1 files changed, 6 insertions, 15 deletions
diff --git a/Mk/Uses/ghostscript.mk b/Mk/Uses/ghostscript.mk
index 98fd5012fc03..720378f9e207 100644
--- a/Mk/Uses/ghostscript.mk
+++ b/Mk/Uses/ghostscript.mk
@@ -6,8 +6,8 @@
# Usage: USES=ghostscript or USES=ghostscript:args
# Valid ARGS: <version>, build, run, x11
#
-# version The chooseable versions are 7, 8 and 9. If no version is
-# specified version 9 is selected.
+# version The chooseable versions are 7, 8, 9 and agpl. If no version is
+# specified version agpl is selected.
#
# USES=ghostscript:7 # Use Ghostscript 7
# USES=ghostscript:run # Use the set default Ghostscript as a run dependancy
@@ -61,31 +61,22 @@ _GS_BUILD_DEP= yes
_GS_RUN_DEP= yes
.endif
-.undef _GS_AGPL_SUFFIX
.undef _GS_SELECTED
.for V in ${_GS_ARGS} ${GHOSTSCRIPT_DEFAULT}
_V=${V}
.if ${_V:M9}
_GS_SELECTED?= 9
.elif ${_V:Magpl}
-_GS_AGPL_SUFFIX?= -agpl
-.if defined(_GS_SELECTED) && ${_GS_SELECTED:N9}
-IGNORE?= Ghostscript-agpl is only available in version 9
-.else
-_GS_SELECTED?= 9
-.endif
+_GS_SELECTED?= 9-agpl
.elif ${_V:M8}
_GS_SELECTED?= 8
.elif ${_V:M7}
_GS_SELECTED?= 7
.endif
.endfor
-.if !defined(_GS_SELECTED)
-IGNORE?= Invalid ghostscript argument or GHOSTSCRIPT_DEFAULT
-.endif
# Resolve minor version number for X11.so library.
-.if !empty(_GS_SELECTED:M9) && defined(_GS_AGPL_SUFFIX)
+.if !empty(_GS_SELECTED:M9-agpl)
_GS_VERSION_MINOR= 9.16_2
.elif !empty(_GS_SELECTED:M9)
_GS_VERSION_MINOR= 9.06_11
@@ -96,8 +87,8 @@ _GS_VERSION_MINOR= 7.07_32
.endif
# dependencies
-_GS_PORT= ghostscript${_GS_SELECTED}${_GS_AGPL_SUFFIX}-base
-_GS_X11_PORT= ghostscript${_GS_SELECTED}${_GS_AGPL_SUFFIX}-x11
+_GS_PORT= ghostscript${_GS_SELECTED}-base
+_GS_X11_PORT= ghostscript${_GS_SELECTED}-x11
.for type in BUILD RUN
.if defined(_GS_${type}_DEP)