aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Uses
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-09-10 03:42:46 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-09-10 03:42:46 +0800
commit6e502d51f3f34690037f4f33bb5cf0f0f50e2ca7 (patch)
treeb3bdcd25b598432ef78aefb0f72e9412f429eee4 /Mk/Uses
parentb236a9c0408bb4c5dd28e3128687a5de61161a27 (diff)
downloadfreebsd-ports-gnome-6e502d51f3f34690037f4f33bb5cf0f0f50e2ca7.tar.gz
freebsd-ports-gnome-6e502d51f3f34690037f4f33bb5cf0f0f50e2ca7.tar.zst
freebsd-ports-gnome-6e502d51f3f34690037f4f33bb5cf0f0f50e2ca7.zip
Most commonly used build systems support silent builds, when they
hide actual commands executed and only show short summary line (like "CC foo.c"). CMake and ninja enable this by default, some autotools using ports do as well. This is unacceptable because we need complete build logs at any time, so we now switch to verbose build logs unconditionally. Note that this change deliberately affects ALL builds and not only package builds on cluster, because we need to be sure that user experiencing failure can always provide informative build log regardless of settings and without rerunning the build. Change summary: - Always do verbose builds for cmake, ninja and GNU configure (the latter includes check if --disable-silent-rules is actually supported by the configure script; there are isolated cases when it's not true) - Remove CMAKE_VERBOSE, NINJA_VERBOSE and CONFIGURE_ARGS=--disable-silent-rules from all ports which set them for this is no longer needed - Revert hacks for --disable-silent-rules support priorly committed to biology/ncbi-blast+ and net-p2p/mldonkey - no longer needed as well Submitted by: amdmi3 Reviewed by: mat Exp-run by: antoine Approved by: portmgr (mat, antoine) Differential Revision: D7534
Diffstat (limited to 'Mk/Uses')
-rw-r--r--Mk/Uses/cmake.mk9
-rw-r--r--Mk/Uses/ninja.mk5
2 files changed, 2 insertions, 12 deletions
diff --git a/Mk/Uses/cmake.mk b/Mk/Uses/cmake.mk
index 193c75641329..de1c81a94499 100644
--- a/Mk/Uses/cmake.mk
+++ b/Mk/Uses/cmake.mk
@@ -12,8 +12,6 @@
# Additional variables that affect cmake behaviour:
#
# User defined variables:
-# CMAKE_VERBOSE - Enable verbose build output
-# Default: not set, unless BATCH or PACKAGE_BUILDING is defined
# CMAKE_NOCOLOR - Disable colour build output
# Default: not set, unless BATCH or PACKAGE_BUILDING is defined
# CMAKE_NINJA - Use ninja instead of make(1)
@@ -80,18 +78,15 @@ CMAKE_ARGS+= -DCMAKE_C_COMPILER:STRING="${CC}" \
-DCMAKE_INSTALL_PREFIX:PATH="${CMAKE_INSTALL_PREFIX}" \
-DCMAKE_BUILD_TYPE:STRING="${CMAKE_BUILD_TYPE}" \
-DTHREADS_HAVE_PTHREAD_ARG:BOOL=YES \
- -DCMAKE_INSTALL_RPATH_USE_LINK_PATH=YES
+ -DCMAKE_INSTALL_RPATH_USE_LINK_PATH=YES \
+ -DCMAKE_VERBOSE_MAKEFILE:BOOL=ON
CMAKE_INSTALL_PREFIX?= ${PREFIX}
.if defined(BATCH) || defined(PACKAGE_BUILDING)
-CMAKE_VERBOSE= yes
CMAKE_NOCOLOR= yes
.endif
-.if defined(CMAKE_VERBOSE)
-CMAKE_ARGS+= -DCMAKE_VERBOSE_MAKEFILE:BOOL=ON
-.endif
.if defined(CMAKE_NOCOLOR)
CMAKE_ARGS+= -DCMAKE_COLOR_MAKEFILE:BOOL=OFF
.endif
diff --git a/Mk/Uses/ninja.mk b/Mk/Uses/ninja.mk
index 30029f692963..2345d740aa92 100644
--- a/Mk/Uses/ninja.mk
+++ b/Mk/Uses/ninja.mk
@@ -5,9 +5,6 @@
# Feature: ninja
# Usage: USES=ninja
#
-# User defined variables:
-# NINJA_VERBOSE - Enable verbose output.
-#
# MAINTAINER: portmgr@FreeBSD.org
.if !defined(_INCLUDE_USES_NINJA_MK)
@@ -17,9 +14,7 @@ _INCLUDE_USES_NINJA_MK= yes
IGNORE= Incorrect 'USES+= ninja:${ninja_ARGS}' ninja takes no arguments
.endif
-.if defined(NINJA_VERBOSE)
MAKE_ARGS+= -v
-.endif
BUILD_DEPENDS+= ninja:devel/ninja