aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Uses
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-06-16 21:21:06 +0800
committermat <mat@FreeBSD.org>2016-06-16 21:21:06 +0800
commit704833a8a2f2565c3e7db684e85c759a2113dc3f (patch)
treeca1e5f9a8700c09bbaf77dd27d3581394329708d /Mk/Uses
parent75dc9ff42994fad3d58052a64deedc32a24dab63 (diff)
downloadfreebsd-ports-gnome-704833a8a2f2565c3e7db684e85c759a2113dc3f.tar.gz
freebsd-ports-gnome-704833a8a2f2565c3e7db684e85c759a2113dc3f.tar.zst
freebsd-ports-gnome-704833a8a2f2565c3e7db684e85c759a2113dc3f.zip
Fix USES=bdb.
Turns out that the conversion to USES was broken, and did not take the DEFAULT_VERSIONS=bdb=foo into account. PR: 210149 Submitted by: mat Exp-run by: antoine Sponsored by: The FreeBSD Foundation, Absolight
Diffstat (limited to 'Mk/Uses')
-rw-r--r--Mk/Uses/bdb.mk14
1 files changed, 7 insertions, 7 deletions
diff --git a/Mk/Uses/bdb.mk b/Mk/Uses/bdb.mk
index a739515e3593..3b87200ac3f6 100644
--- a/Mk/Uses/bdb.mk
+++ b/Mk/Uses/bdb.mk
@@ -65,6 +65,8 @@ WARNING+= "WITH_BDB_VER is deprecated and will be removed on 2016-08-01. Use DEF
BDB_DEFAULT:=${WITH_BDB_VER}
.endif
+.include "${PORTSDIR}/Mk/bsd.default-versions.mk"
+
_BDB_DEFAULT_save:=${BDB_DEFAULT}
_DB_PORTS= 48 5 6
@@ -91,11 +93,13 @@ BDB_DEFAULT= ${${BDB_UNIQUENAME:tu:S,-,_,}_WITH_BDB_VER}
# Override _bdb_ARGS with global BDB_DEFAULT if the maintainer did not
# ask for a more specific version.
-.if defined(BDB_DEFAULT)
-. if ${BDB_DEFAULT} != 1
+. if ${_bdb_ARGS} == yes
+. if ${BDB_DEFAULT} != 1
_bdb_ARGS= ${BDB_DEFAULT}
+. else
+_bdb_ARGS:= 48+
+. endif
. endif
-.endif
# Compatiblity hack:
# upgrade older plussed versions to 48+
@@ -106,10 +110,6 @@ _bdb_ARGS:= 48+
. endif
.endfor
-.if ${_bdb_ARGS} == yes
-_bdb_ARGS:= 48+
-.endif
-
# 1. detect installed versions
_INST_BDB_VER=
.for bdb in ${_DB_PORTS}