aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Uses
diff options
context:
space:
mode:
authorjrm <jrm@FreeBSD.org>2018-01-10 04:06:34 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 06:21:32 +0800
commit2fa3c5701871269f6216fb26f41e2893a1fc59b2 (patch)
tree0299b61493a2318d23464fbf557ea34b2a13a5d1 /Mk/Uses
parentd5a346855e6665c070744f6d4229922ba3af48f9 (diff)
downloadfreebsd-ports-gnome-2fa3c5701871269f6216fb26f41e2893a1fc59b2.tar.gz
freebsd-ports-gnome-2fa3c5701871269f6216fb26f41e2893a1fc59b2.tar.zst
freebsd-ports-gnome-2fa3c5701871269f6216fb26f41e2893a1fc59b2.zip
New ports: www/py-qt5-webchannel and www/py-qt5-webengine
Reviewed by: mat, tcberner Approved by: tcberner Differential Revision: https://reviews.freebsd.org/D12964
Diffstat (limited to 'Mk/Uses')
-rw-r--r--Mk/Uses/pyqt.mk9
1 files changed, 8 insertions, 1 deletions
diff --git a/Mk/Uses/pyqt.mk b/Mk/Uses/pyqt.mk
index 59b85dcb5fb4..507c6f44cb7e 100644
--- a/Mk/Uses/pyqt.mk
+++ b/Mk/Uses/pyqt.mk
@@ -75,6 +75,7 @@ QSCI2_DISTNAME= QScintilla-gpl-${QSCI2_VERSION}
PYQT4_LICENSE= GPLv3
PYQT5_LICENSE= GPLv3
+# Keep these synchronized with OPTIONS_DEFINE in devel/py-qt4 and devel/py-qt5
# PyQt components split up into pyqt4/pyqt5/...
_USE_PYQT_ALL= core dbus dbussupport demo designer designerplugin \
gui multimedia network opengl qscintilla2 \
@@ -84,7 +85,7 @@ _USE_PYQT4_ONLY= assistant declarative doc \
help phonon script scripttools
# List of components only in pyqt5
_USE_PYQT5_ONLY= multimediawidgets printsupport qml serialport \
- webkitwidgets widgets
+ webchannel webengine webkitwidgets widgets
# Unversioned variables for the rest of the file
PYQT_VERSION= ${PYQT${_PYQT_VERSION}_VERSION}
@@ -118,6 +119,8 @@ py-scripttools_PATH= ${PYQT_PY_RELNAME}-scripttools>=${PYQT_VERSION}
py-sql_PATH= ${PYQT_PY_RELNAME}-sql>=${PYQT_VERSION}
py-svg_PATH= ${PYQT_PY_RELNAME}-svg>=${PYQT_VERSION}
py-test_PATH= ${PYQT_PY_RELNAME}-test>=${PYQT_VERSION}
+py-webchannel_PATH= ${PYQT_PY_RELNAME}-webchannel>=${PYQT_VERSION}
+py-webengine_PATH= ${PYQT_PY_RELNAME}-webengine>=${PYQT_VERSION}
py-webkit_PATH= ${PYQT_PY_RELNAME}-webkit>=${PYQT_VERSION}
py-xml_PATH= ${PYQT_PY_RELNAME}-xml>=${PYQT_VERSION}
py-xmlpatterns_PATH= ${PYQT_PY_RELNAME}-xmlpatterns>=${PYQT_VERSION}
@@ -152,6 +155,8 @@ py-scripttools_PORT= devel/${PYQT_RELNAME}-scripttools
py-sql_PORT= databases/${PYQT_RELNAME}-sql
py-svg_PORT= graphics/${PYQT_RELNAME}-svg
py-test_PORT= devel/${PYQT_RELNAME}-test
+py-webchannel_PORT= www/${PYQT_RELNAME}-webchannel
+py-webengine_PORT= www/${PYQT_RELNAME}-webengine
py-webkit_PORT= www/${PYQT_RELNAME}-webkit
py-xml_PORT= textproc/${PYQT_RELNAME}-xml
py-xmlpatterns_PORT= textproc/${PYQT_RELNAME}-xmlpatterns
@@ -184,6 +189,8 @@ py-scripttools_DESC= Python bindings for QtScriptTools module
py-sql_DESC= Python bindings for QtSql module
py-svg_DESC= Python bindings for QtSvg module
py-test_DESC= Python bindings for QtTest module
+py-webchannel_DESC= Python bindings for QtWebChannel module
+py-webengine_DESC= Python bindings for QtWebEngine module
py-webkit_DESC= Python bindings for QtWebKit module
py-xml_DESC= Python bindings for QtXml module
py-xmlpatterns_DESC= Python bindings for QtXmlPatterns module