aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Uses
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-12-11 20:41:56 +0800
committermat <mat@FreeBSD.org>2017-12-11 20:41:56 +0800
commit1ac28698888792a116cbae92e0a1a83878509066 (patch)
treebee66b717668c6688e4720715f5ba32ca949fec4 /Mk/Uses
parent611b648aca1588ffea64b46246d81e58cb0c012a (diff)
downloadfreebsd-ports-gnome-1ac28698888792a116cbae92e0a1a83878509066.tar.gz
freebsd-ports-gnome-1ac28698888792a116cbae92e0a1a83878509066.tar.zst
freebsd-ports-gnome-1ac28698888792a116cbae92e0a1a83878509066.zip
Make USE_PYTHON=concurrent flavors friendly.
Before, it would only create the default symlink if the Python version was the default Python version. Change that to if the Python flavor is the default flavor. PR: 224242 Sponsored by: Absolight
Diffstat (limited to 'Mk/Uses')
-rw-r--r--Mk/Uses/python.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/Mk/Uses/python.mk b/Mk/Uses/python.mk
index 74def686480f..9030c3ab6f5e 100644
--- a/Mk/Uses/python.mk
+++ b/Mk/Uses/python.mk
@@ -567,7 +567,9 @@ RUN_DEPENDS+= cython-${PYTHON_VER}:lang/cython@${PY_FLAVOR}
.if defined(_PYTHON_FEATURE_CONCURRENT)
_USES_POST+= uniquefiles:dirs
-.if ${PYTHON_VERSION} == ${PYTHON_DEFAULT_VERSION}
+.if defined(_PYTHON_FEATURE_FLAVORS) && ${FLAVOR} == ${FLAVORS:[1]}
+UNIQUE_DEFAULT_LINKS= yes
+.elif !defined(_PYTHON_FEATURE_FLAVORS) && ${PYTHON_VERSION} == ${PYTHON_DEFAULT_VERSION}
UNIQUE_DEFAULT_LINKS= yes
.else
UNIQUE_DEFAULT_LINKS= no