aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Uses
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-02-15 20:34:49 +0800
committermat <mat@FreeBSD.org>2018-02-15 20:34:49 +0800
commitef3c2f92f74f30886114eab9201e86f48dcb026d (patch)
treebf19f32ea6808c09829f1a5d7bde66757b0d8790 /Mk/Uses
parent644aeb581e7615d27d404a74f183abbe17284967 (diff)
downloadfreebsd-ports-gnome-ef3c2f92f74f30886114eab9201e86f48dcb026d.tar.gz
freebsd-ports-gnome-ef3c2f92f74f30886114eab9201e86f48dcb026d.tar.zst
freebsd-ports-gnome-ef3c2f92f74f30886114eab9201e86f48dcb026d.zip
devel/boost-python-libs got forgotten in the python flavorization, fix
this oversight. Reviewed by: antoine Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D14368
Diffstat (limited to 'Mk/Uses')
-rw-r--r--Mk/Uses/python.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/Mk/Uses/python.mk b/Mk/Uses/python.mk
index 767a26d44b7b..ac9cb699c386 100644
--- a/Mk/Uses/python.mk
+++ b/Mk/Uses/python.mk
@@ -671,6 +671,13 @@ PY_FUTURES= ${PYTHON_PKGNAMEPREFIX}futures>0:devel/py-futures@${PY_FLAVOR}
PY_FUTURES=
.endif
+.if ${PYTHON_REL} < 3000
+PY_BOOST_LIB= boost_python
+.else
+PY_BOOST_LIB= boost_python3
+.endif
+PY_BOOST= lib${PY_BOOST_LIB}.so:devel/boost-python-libs@${PY_FLAVOR}
+
# dependencies
.for _stage in PATCH BUILD RUN TEST
. if defined(_PYTHON_${_stage}_DEP)